US Fender on Canadian bike - Road Glide Forums
Lighting Lighting for Road Gildes

 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 26 (permalink) Old 07-15-2019, 12:20 PM Thread Starter
Newbie
 
Join Date: Dec 2018
Location: Halifax, NS. Canada
Posts: 13
US Fender on Canadian bike

Hey guys, new to the Harley world and to this forum. I just picked up a 2019 RGS. Love the bike, except the taillight. I live in Canada, so we have the big taillight on the rear fender. I managed to pick up a US rear fender to match my billiard blue off eBay. Iíve been searching the forums and cant find anyone that has done this before. I know the wiring harnesses are different, but people also get the CVO fender and make that work, which would be similar to this. Just wondering if anyone has done any wiring related to something like this? Thanks for the help.
PrimePower is offline  
Sponsored Links
Advertisement
 
post #2 of 26 (permalink) Old 07-15-2019, 01:31 PM
Life Member
 
Join Date: Sep 2010
Location: FL
Posts: 6,407
Welcome, sorry I cannot help on your question.
PrimePower likes this.

2018 FLTRXS, Vivid Black, KW Slicer Front Fender, Sundowner Seat/Modified by Mean City Cycle
FLTRXS18 is offline  
post #3 of 26 (permalink) Old 07-23-2019, 08:29 AM Thread Starter
Newbie
 
Join Date: Dec 2018
Location: Halifax, NS. Canada
Posts: 13
So I have my US fender and plugged it in. Everything works except the brakes. Running, TriBar, license plate and signals all work. Anyone on here have any idea what wires should be changed to get the brakes working? Thanks!
PrimePower is offline  
 
post #4 of 26 (permalink) Old 07-23-2019, 09:00 AM Thread Starter
Newbie
 
Join Date: Dec 2018
Location: Halifax, NS. Canada
Posts: 13
More info. Iíve tried switching plugs around and still nothing. Although now, when I plug it straight into the harness on the bike, I only get the right signal to light up. I plug the factory rear lights in and they all work, with signals and everything. Any help would be great. Thanks
PrimePower is offline  
post #5 of 26 (permalink) Old 07-23-2019, 09:01 AM
Life Member
 
BH#103's Avatar
 
Join Date: Jun 2012
Location: Illinois
Posts: 1,754
You are dealing with the harness that was already on your bike correct? Only the fender with the lights was changed?

2019 Silver Flux/Black Fuse FLTRU
"SLIVER"
BH#103 is online now  
post #6 of 26 (permalink) Old 07-23-2019, 09:18 AM Thread Starter
Newbie
 
Join Date: Dec 2018
Location: Halifax, NS. Canada
Posts: 13
Correct. The main harness on the bike is stock. Iím using the rear lighting harness from the US fender. I know the wiring will change slightly, due to the lack of a centre taillight and the TriBar light.
PrimePower is offline  
post #7 of 26 (permalink) Old 07-23-2019, 09:27 AM
Life Member
 
BH#103's Avatar
 
Join Date: Jun 2012
Location: Illinois
Posts: 1,754
Quote:
Originally Posted by PrimePower View Post
Correct. The main harness on the bike is stock. I’m using the rear lighting harness from the US fender. I know the wiring will change slightly, due to the lack of a centre taillight and the TriBar light.
Just to be clear on this. With the US fender harness plugged into the Canadian bike harness you have everything working except for brake lights. Is that correct?

2019 Silver Flux/Black Fuse FLTRU
"SLIVER"
BH#103 is online now  
post #8 of 26 (permalink) Old 07-23-2019, 10:27 AM Thread Starter
Newbie
 
Join Date: Dec 2018
Location: Halifax, NS. Canada
Posts: 13
Well, when I first plugged it in, yes. But now, I have a code, which I cleared. Now the only thing that works is the right signal and i thinks itís actually both filaments on. So brake light on right side and thatís it. I figured the bike probably powered everything up first and then shut it down.
PrimePower is offline  
post #9 of 26 (permalink) Old 07-23-2019, 11:13 AM
Life Member
 
BH#103's Avatar
 
Join Date: Jun 2012
Location: Illinois
Posts: 1,754
Got a manual and a test light? I would figure out what wire is for what on the bike side and make sure it gets to the corresponding wire on the fender harness connector.

2019 Silver Flux/Black Fuse FLTRU
"SLIVER"
BH#103 is online now  
post #10 of 26 (permalink) Old 07-23-2019, 11:23 AM Thread Starter
Newbie
 
Join Date: Dec 2018
Location: Halifax, NS. Canada
Posts: 13
I just downloaded a wiring harness diagram. Going to start testing now. I believe the wires swap to different pins at some point. Thanks
PrimePower is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome