527 red shift - Road Glide Forums
Engine Related Engine Builds and more for Road Glides

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-27-2014, 06:14 PM Thread Starter
Newbie
 
Join Date: Sep 2010
Posts: 47
527 red shift

I had Red Shift cams installed on my bike 2011 RGU 103
527 cams S&S push rods Fueling lifters zippers chain tensioners and oil valve
K&P oil filter Reinhart mufflers Rush header pipe and Thunder max tuner
I was told the 527 where to be a quiet cam .had valves adjusted all diff ways
1st by spec 3 3/4
2nd 4 1/4
3rd bottom and 4 flats
old lifters and new lifters same tap sounds like a motor with little oil and I am running Lucas 50w syn with 38psi and 15psi at idle hot
Anybody using 527 cams and having this problem. I can only play my radio so loud
hd2011 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-28-2014, 11:50 AM
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,528
Looks like you may be over adjusting the pushrods. In most cases 2 3/4 to 3 1/4 turns is all thet is required. It depends on how many threads per inch you have on the pushrod some pushrods are 16 threads per inch and some are 24 threads per inch.
I may be wrong but I think the S&S pushrods are 24 threads pre inch and somewhere around 18 flats or 3 turns should get you in the correct range.
You should turn the engine over until the cam is on the base circle then adjust the lose pushrod by hand until it makes contact with the rocker and the lifter, you can tell because you can not move the pushrod up or down.
Then do the 3 turns on the pushrods and after approx 10 minutes you should be able to spin the pushrod by hand.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
post #3 of 4 (permalink) Old 05-28-2014, 12:20 PM Thread Starter
Newbie
 
Join Date: Sep 2010
Posts: 47
Quote:
Originally Posted by ironmark View Post
Looks like you may be over adjusting the pushrods. In most cases 2 3/4 to 3 1/4 turns is all thet is required. It depends on how many threads per inch you have on the pushrod some pushrods are 16 threads per inch and some are 24 threads per inch.
I may be wrong but I think the S&S pushrods are 24 threads pre inch and somewhere around 18 flats or 3 turns should get you in the correct range.
You should turn the engine over until the cam is on the base circle then adjust the lose pushrod by hand until it makes contact with the rocker and the lifter, you can tell because you can not move the pushrod up or down.
Then do the 3 turns on the pushrods and after approx 10 minutes you should be able to spin the pushrod by hand.
The specs where from fueling and red shift. Zippers specs all the way down than 4 flats Do you any body running 527 cams and are they quiet
Thanks for the input
hd2011 is offline  
 
post #4 of 4 (permalink) Old 05-28-2014, 12:29 PM
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,528
Quote:
Originally Posted by hd2011 View Post
The specs where from fueling and red shift. Zippers specs all the way down than 4 flats Do you any body running 527 cams and are they quiet
Thanks for the input
Your lifters are bottomed out. The lifter has approx 1 inch of travel and you should be set at the center of the lifters travel, this will allow the lifter to pump up and pump oil to the top end of the engine.
If the lifter is bottomed out it will not pump the oil to the top of the engine causing top end noise and possible engine damage.
The proceedure I posted is the correct proceedure to adjust adjustable pushrods according to HD and S&S so give it a try.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Red Shift 525 cams TRUBlue Engine Related 12 09-06-2012 10:25 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome