Cam Install possible issue - Road Glide Forums
Engine Related Engine Builds and more for Road Glides

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 07-03-2014, 03:31 PM Thread Starter
Prospect
 
Join Date: Sep 2013
Location: North Central, Indiana
Posts: 251
Cam Install possible issue

I just installed drago's 565 cams in my bike. After checking the crank and cam sprocket alignment. When I put the chain back on I didnt pay attention to the dots and the timing was off and the bike wouldnt start. I started over and got it right and the bike fired right up. I set the the pushrods at 4 turn per S&S's instructions. And installed new lifters as well. Only has a little miss/stumble at about 2500-3k with the generic map I have, other than that seems alright.

What are the chances I hurt the valves while trying to start it with the timing off? Would it run really bad if the valve was bent?

I am going start by getting a compression tester seeing what the reading is. I want to make sure all is good before sending for Dyno tuning.

Makes me feel like a idiot that I goofed it up. But SH*T happens I guess.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

[B]PV-Big Sucker-Rush Racing H-pipe-Big Louie's-Drago's 565 cams

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Nightrain04; 07-03-2014 at 03:35 PM.
Nightrain04 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 07-03-2014, 03:42 PM
Grey beard
 
pat123's Avatar
 
Join Date: Sep 2012
Location: Canton,Georgia
Posts: 1,066
It's the tune. If you bent a valve it would run bad from idle to redline. Not just at 2500-3k.

I a compression test to make sure.
pat123 is offline  
post #3 of 13 (permalink) Old 07-03-2014, 04:17 PM Thread Starter
Prospect
 
Join Date: Sep 2013
Location: North Central, Indiana
Posts: 251
Quote:
Originally Posted by pat123 View Post
It's the tune. If you bent a valve it would run bad from idle to redline. Not just at 2500-3k.

I a compression test to make sure.
That is my next step.

Sent from Motorcycle.com Free App


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

[B]PV-Big Sucker-Rush Racing H-pipe-Big Louie's-Drago's 565 cams

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Nightrain04 is offline  
 
post #4 of 13 (permalink) Old 07-06-2014, 09:14 AM
Member
 
MyGlide's Avatar
 
Join Date: Sep 2012
Location: Lufkin, Texas
Posts: 568
Odds are you're alright and its just the tune. Generic maps are just a starting point to get you in the ballpark.

2018 FLTRU S&S 124 cyl & piston kit with assorted goodies (136 hp 140 tq)SAE
2018 KTM Super Duke R
MyGlide is offline  
post #5 of 13 (permalink) Old 07-06-2014, 10:03 AM Thread Starter
Prospect
 
Join Date: Sep 2013
Location: North Central, Indiana
Posts: 251
Quote:
Originally Posted by MyGlide View Post
Odds are you're alright and its just the tune. Generic maps are just a starting point to get you in the ballpark.
I got a tester and will check later on today. I am also wanting on my Rush racing h-pipe to get here before dyno tuning.

Sent from Motorcycle.com Free App


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

[B]PV-Big Sucker-Rush Racing H-pipe-Big Louie's-Drago's 565 cams

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Nightrain04 is offline  
post #6 of 13 (permalink) Old 07-06-2014, 11:30 AM
GONE BUT NOT FORGOTTEN
 
faststan's Avatar
 
Join Date: Jun 2011
Location: Port Orange, Fl
Posts: 1,775
Did you check the location of the O2 sensors, gray/front black/rear. You must have removed the exhaust to put in cams.

11 FLTRU 103 Red Hot Sunglow
Rush True Duals,Air ride,Madstad, SE 255 cams, Ventilator,bunch of other stuff
faststan is offline  
post #7 of 13 (permalink) Old 07-06-2014, 11:41 AM Thread Starter
Prospect
 
Join Date: Sep 2013
Location: North Central, Indiana
Posts: 251
I only took off the rear pipe as I have true duals. I only unplugged the rear sensor(grey).

My guess is the tune as well. As it runs pretty decent. What I have read it would run pretty horrible with bent valves. Maybe I dodged a bullet with my error on reassembly.

I will probably have valley racing in IL do the dyno tune on it. They seem to have a great rep on the forums.

Sent from Motorcycle.com Free App


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

[B]PV-Big Sucker-Rush Racing H-pipe-Big Louie's-Drago's 565 cams

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Nightrain04; 07-06-2014 at 11:48 AM.
Nightrain04 is offline  
post #8 of 13 (permalink) Old 07-06-2014, 11:48 AM
Prospect
 
kouack's Avatar
 
Join Date: Aug 2012
Location: Montréal, Canada.
Posts: 211
Garage
What are you using for tune, you are not saying if you are using a tts,pc,pv etc... I guess only the stock ecm?

Sent from Motorcycle.com Free App

Road glide custom 2013, Stage one AC from FM, E serie fuel moto 2 into 1, PC5 with autune,Andrews 57 stick.
kouack is offline  
post #9 of 13 (permalink) Old 07-06-2014, 11:49 AM Thread Starter
Prospect
 
Join Date: Sep 2013
Location: North Central, Indiana
Posts: 251
Quote:
Originally Posted by kouack View Post
What are you using for tune, you are not saying if you are using a tts,pc,pv etc... I guess only the stock ecm?

Sent from Motorcycle.com Free App
A power vision. Drago provided a base map. I feel I am best off to just have it tuned.

Sent from Motorcycle.com Free App


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

[B]PV-Big Sucker-Rush Racing H-pipe-Big Louie's-Drago's 565 cams

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Nightrain04 is offline  
post #10 of 13 (permalink) Old 07-06-2014, 12:26 PM
Grey beard
 
pat123's Avatar
 
Join Date: Sep 2012
Location: Canton,Georgia
Posts: 1,066
Frank gave me a tune for my 580 cams and it sucked bad. I pro auto tuned it 15 times and could never get it below 18%. It wanted to cap or scale the tune every session. I ended up using a fuel moto tune for woods 555 cams and got it spot on in 4 auto tune sessions. It runs great now.


If you want I can send you this map. Might be closer.
pat123 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Possible clutch issue. Chromedclassic Engine Related 1 03-20-2016 07:24 PM
help. cam swap issue milkman48 Engine Related 7 04-01-2015 07:11 AM
Is there still a cam tensioner issue mr_reality Engine Related 24 04-11-2014 06:23 AM
Electrical possible sensor issue...??? Johnzz1420 *General Road Glide Discussions/Pictures 5 08-05-2013 05:31 PM
Apparently, this isn't my week. Possible clutch issue RGCBandit Troubleshooting for Road Glides 3 10-15-2012 09:53 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome