help..... no oil pressure - Road Glide Forums
Engine Related Engine Builds and more for Road Glides

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 08-22-2014, 09:24 PM Thread Starter
Newbie
 
Join Date: Feb 2014
Location: mi
Posts: 35
help..... no oil pressure

Just changed out cams in my 12 rg from 777 to tw8-6 and now have no oil pressure. Competed install and fired up first time seen it had no pressure and shut down and thought. Only thing I could do is take it all back apart and inspected everything found nothing. Replaced all O-rings again for good measure and reassembled with same results. Even tried pressurizing crank case to no avail. On way home got thinking maybe sender is bad will check that tomorrow but I aint that lucky lol. Any ideas or insight would be appreciated as I'm fresh out of them.
drnovaman is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 08-22-2014, 09:37 PM
Prospect
 
TimmyG's Avatar
 
Join Date: May 2013
Location: Madison Ohio
Posts: 270
Is there oil in it?
TimmyG is offline  
post #3 of 8 (permalink) Old 08-22-2014, 09:53 PM Thread Starter
Newbie
 
Join Date: Feb 2014
Location: mi
Posts: 35
yes good question though sometimes its easy to overlook the obvious.
drnovaman is offline  
 
post #4 of 8 (permalink) Old 08-22-2014, 10:36 PM
Life Member
 
Hullhorr's Avatar
 
Join Date: Feb 2011
Location: Mt. Airy, MD
Posts: 6,081
Check the relief valve and relief spring in the cam support plate. They have been known to go bad. I would also make sure you have the oil pump aligned correctly with the lobes on the crankshaft if you removed it when you did your cams.

2009 FLTR MOP
"A Goverment should fear it's people not vice versa"
Hullhorr is offline  
post #5 of 8 (permalink) Old 08-23-2014, 05:15 AM
Grey beard
 
FrankieB's Avatar
 
Join Date: May 2011
Location: Kentucky
Posts: 809
Quote:
Originally Posted by Hullhorr View Post
Check the relief valve and relief spring in the cam support plate. They have been known to go bad. I would also make sure you have the oil pump aligned correctly with the lobes on the crankshaft if you removed it when you did your cams.
^^^this and also if you took the oil pump off, make sure the oil pump pieces were put back on in the correct order.

06 RK
11 RGU
FrankieB is offline  
post #6 of 8 (permalink) Old 08-23-2014, 06:00 PM Thread Starter
Newbie
 
Join Date: Feb 2014
Location: mi
Posts: 35
Quote:
Originally Posted by FrankieB View Post
^^^this and also if you took the oil pump off, make sure the oil pump pieces were put back on in the correct order.
we have a winner feel like a dumb ass but its all good now. I guess sometimes one should look at the pictures.
drnovaman is offline  
post #7 of 8 (permalink) Old 08-23-2014, 08:05 PM
Member
 
staush's Avatar
 
Join Date: Jan 2011
Location: LAS VEGAS,NV
Posts: 593
Oil pressure

Ok (winner that feels like a dumb ass) we've all been there. What was it, oil or bad assembly?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2011 Road- Glide Custom-stock engine w/K&N air filter. I like it quiet.
staush is offline  
post #8 of 8 (permalink) Old 08-23-2014, 10:15 PM
Grey beard
 
FrankieB's Avatar
 
Join Date: May 2011
Location: Kentucky
Posts: 809
Quote:
Originally Posted by staush View Post
Ok (winner that feels like a dumb ass) we've all been there. What was it, oil or bad assembly?
I am guessing the wavey washers where put in the wrong order.

06 RK
11 RGU
FrankieB is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
NO OIL and no idiot light?? motodrummer Troubleshooting for Road Glides 16 06-18-2015 10:48 PM
Help Oil Pressure cdc3660 Engine Related 12 04-06-2014 11:21 AM
High Oil Pressure and High Oil Temps ironmark Troubleshooting for Road Glides 17 12-09-2012 10:44 AM
No oil pressure Double0 Troubleshooting for Road Glides 12 09-19-2012 12:03 AM
Oil pressure gauge 2010fltrx Troubleshooting for Road Glides 1 08-16-2010 04:09 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome