Help sorry this was posted in the wrong forum earlier - Road Glide Forums
Engine Related Engine Builds and more for Road Glides

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-25-2014, 04:43 PM Thread Starter
Newbie
 
Join Date: Jan 2014
Posts: 7
Help sorry this was posted in the wrong forum earlier

I just installed a COBRA power flo air cleaner, FI2000 power pro tuner and COBRA pipes and mufflers. Im getting backfiring when I back off the throttle. I've got about 60 miles on the exhaust and wondering if I need more time to have the tuner cycle and cure the problem. Any ideas?
vincepicone is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-25-2014, 08:18 PM
Member
 
FDR's RGC's Avatar
 
Join Date: Jan 2013
Posts: 548
Double check for exhaust leaks.
FDR's RGC is offline  
post #3 of 3 (permalink) Old 08-26-2014, 02:23 AM
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,528
The newer Fi 2000 don't have the adjustment pods so there is nothing you can do. If you don't have a exhaust leak you are most likely running to lean on decel and you need to have some fuel added on decel.
The older styler Fi2000 have adjustment pods and it is easy to adjust.
You may consider taking the Fi2000 off and take the bike to HD and have the ECM reflashed than re-install the Fi2000, it may take care of your problem.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Posted in wrong section Pattywagon Dyno Results 0 04-24-2016 06:23 PM
Posted in the wrong section! Doug06rg Dyno Results 0 04-21-2016 05:26 PM
Help and sorry 4 being a pain pipe3214 ECM/Fuel Management systems 13 04-09-2015 11:39 PM
Sorry I haven't posted laxinharley General Off-Topic Discussions 11 03-16-2015 09:17 AM
Posted this on HD Forum, as to my being maybe? ddm502001 General Off-Topic Discussions 11 10-24-2013 06:56 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome