Possible clutch issue. - Road Glide Forums
Engine Related Engine Builds and more for Road Glides

 1Likes
  • 1 Post By Road dawg
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-20-2016, 06:11 PM Thread Starter
Newbie
 
Chromedclassic's Avatar
 
Join Date: Feb 2016
Location: Virginia
Posts: 3
Garage
Possible clutch issue.

408 miles on my new RG. Pulled it into the garage the other night and stared backing it up. Felt like it was trying to go forward so I put it in N and finished backing it up. Went out about 1 hr later to plug in the battery tender and had fluid underneath. No issues with the bakes so I'm assuming its hydraulic fluid from the clutch line. Anyone else had any issues. The dealership came and picked it up yesterday am. Waiting on a diagnosis.
Chromedclassic is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-20-2016, 07:24 PM
Life Member
 
Road dawg's Avatar
 
Join Date: Oct 2011
Location: Long Island, New York
Posts: 2,242
Well I can tell you if your trans fluid is low it will def cause a hard shift or for it to be stuck in gear, I highly doubt you have a clutch issue at 408k, and with fluid on the ground im guessing a leak was the culprit, good luck.
Chromedclassic likes this.

When all else fails, hell there is always beer!
Road dawg is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cam Install possible issue Nightrain04 Engine Related 12 07-07-2014 09:23 AM
Electrical possible sensor issue...??? Johnzz1420 *General Road Glide Discussions/Pictures 5 08-05-2013 05:31 PM
Apparently, this isn't my week. Possible clutch issue RGCBandit Troubleshooting for Road Glides 3 10-15-2012 09:53 AM
stock 103 possible smoked clutch/slipping trans OuchMMC Engine Related 23 10-13-2012 10:29 PM
Clutch issue... ZachB Troubleshooting for Road Glides 21 04-19-2012 08:33 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome