1999 road glide won't idle - Road Glide Forums
Engine Related Engine Builds and more for Road Glides

 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 05-12-2016, 08:48 AM Thread Starter
Newbie
 
Join Date: May 2016
Posts: 6
1999 road glide won't idle

I just bought a 1999 road glide fuel injected. The bike will fire up easy when it's cold. It seems about a minute after starting it will stall and the warmer it gets the more is doesn't want to idle. This is my first Harley and could use some tips,thanks.
Aceswild03 is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 05-12-2016, 10:56 AM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,119
Garage
Is it throwing any codes ? I think back then you got to count light flashes.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
post #3 of 14 (permalink) Old 05-12-2016, 11:19 AM
PGR
GONE BUT NOT FORGOTTEN
 
PGR's Avatar
 
Join Date: Aug 2010
Location: Western Illinois
Posts: 2,338
Garage
A friend had a 1998 Road Glide and his did the same thing. It turned out to be an intake leak between the induction module, and the manifold. Things got a little brittle with age. New intake seals fixed it right up. Cost less than 10 bucks.

To check to see if this is the problem, carefully spray a little brake cleaner on the manifold, making sure none gets in the intake. If the bike suddenly dies, you have a leak. Have someone keep the throttle a little above idle while you do this.








......................
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Ron..........................


........2011 Cool Blue Pearl FLTRX........
.............RoboGlide .............


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by PGR; 05-12-2016 at 11:22 AM.
PGR is offline  
 
post #4 of 14 (permalink) Old 05-12-2016, 11:35 AM
Prospect
 
Root76's Avatar
 
Join Date: Aug 2015
Location: SW Virginia
Posts: 214
Garage
A few times I've gotten bad gas (with water) and the engine wouldn't idle. I was skeptical when the dealer told me to use SeaFoam, however, it ran better immediately. Hope this may be all that's wrong with yours. Good Luck

Midnight Pearl 2013 CFR pipes Khrome Werks handelbars
Root76 is offline  
post #5 of 14 (permalink) Old 05-12-2016, 02:24 PM Thread Starter
Newbie
 
Join Date: May 2016
Posts: 6
So should I check around the air filter for this leak?
Aceswild03 is offline  
post #6 of 14 (permalink) Old 05-12-2016, 02:28 PM
PGR
GONE BUT NOT FORGOTTEN
 
PGR's Avatar
 
Join Date: Aug 2010
Location: Western Illinois
Posts: 2,338
Garage
Quote:
Originally Posted by Aceswild03 View Post
So should I check around the air filter for this leak?

Behind the air filter, you will see a Y shaped tube. The induction module splits into the front and rear jug. That's where they leak. There are 2 seals

Ronnie's Harley-Davidson's 1999 Harley Davidson FLTR-I ROAD GLIDE® - FUEL INJECTION (FS) | FUEL INJECTION ASSEMBLY Parts List


Look at item number 5 in the picture. That's where you want to shoot a little blast of brake cleaner. If there is a leak the engine will shut down really quick.








......................
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Ron..........................


........2011 Cool Blue Pearl FLTRX........
.............RoboGlide .............


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by PGR; 05-12-2016 at 02:30 PM.
PGR is offline  
post #7 of 14 (permalink) Old 05-12-2016, 04:34 PM
Grey beard
 
VikingRider's Avatar
 
Join Date: May 2014
Location: Oslo, Norway
Posts: 1,030
Quote:
Originally Posted by Aceswild03 View Post
I just bought a 1999 road glide fuel injected. The bike will fire up easy when it's cold. It seems about a minute after starting it will stall and the warmer it gets the more is doesn't want to idle. This is my first Harley and could use some tips,thanks.
Hi Aceswild; I have the SERG '01 with the Magneti Marelli EFI. I have had this bike for a couple of years and gotten used to it's "eccentric behavior". The local MoCo mechanic just gave me a smirk when I asked him to fix it. I was told that there are very few mechanics left who really knows how to do it or care to do it...
In 2002 (IIRC) MoCo switched to Delphi-injectors for more than one reason obviously.

Anyhow, apart from the slightly irritating start-up procedure, the bike performs well even with the quirky Italian EFI. I never had any trouble going for long trips; engine revving with ease and performing like an EFI should. After a couple of miles the bike will idle without problem although sometimes it drops to "parade-mode" (nobody told it that this is NOT a feature on this model!

I know of course that a lot of people have chucked the M&M and put in a Mikuni carb. instead. But I am not going to such drastic means as long as the EFI works at full throttle without a glitch.

BUT if you want to spend the money; or to qoute Zipper's performance products: «Stop cussing that early EFI system, just replace it!». It's a very nice product but it will cost you about US$ 2500,00.

http://www.zippersperformance.com/al...e-marelli.html

Just my 2c.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

FLTRSEI2
SE95-AN Stage 2-PCIII - SuperTrapp TDs-Kerker Stouts -KlockWerks Flare "12-Aquatic HU/J&M 7.5 ++ custom

Last edited by VikingRider; 05-12-2016 at 04:36 PM.
VikingRider is offline  
post #8 of 14 (permalink) Old 05-13-2016, 07:38 AM
Member
 
Join Date: Sep 2012
Location: Tn.
Posts: 545
Fuel lines inside the tank could be leaking, and MM pressure regulators are known culprits as well. Many find throwing $$ at it doesn't make it run better, why HD went with Delphi, and many owners change over to a carb.
rg113 is offline  
post #9 of 14 (permalink) Old 05-15-2016, 04:40 AM
Hangaround
 
Join Date: Dec 2014
Location: West Central, Indiana
Posts: 74
I too have a 99. I also had warm idle issues. I had leaking intake seals as others advised you to check .
However I fixed my idle issues by following this you tube video. The screws holding the Throttle position sensor still had the glue in them from the factory so I knew it had never been touched. I do recommend a long torx screwdriver I don't recall the size. It should start and cold fast idle for a few minutes around 1500 rpm and then drop down to 900-1000 warm idle. What this video shows is how to adjust the throttle position sensor. The sensor sends a signal (number) to the ECM so that the ECM knows what position the throttle plates are in. The computer knows a number which he tells in the video but escapes me at this time what "closed" is. Warning- when adjusting this it's the most sensitive SOB in the world. So sensitive that just tightening the screws back down will change the reading. It took several tries to get it just where I wanted it. Use patience.

I've read that its best to start it up and not touch the throttle until after it drops down to warm idle.

Best of luck. it's not as bad as some make the early system out to be, or it hasn't been my experience yet.

https://www.youtube.com/watch?v=bY6Pw8WpSfc
turbochrisb likes this.

1999 Road Glide, 95" Andrews 37, Power Commander 3, D&D Fatcat 2-1, Big Sucker

Last edited by Bill-99RG; 05-15-2016 at 08:54 PM.
Bill-99RG is offline  
post #10 of 14 (permalink) Old 05-15-2016, 11:40 AM
Hangaround
 
Join Date: Apr 2014
Location: Falcon Co
Posts: 69
Nice video, going to try this with my 99 Ultra. Hopefully get it back up to the 45-50 MPG's. Aside from the idle, I have not had any problems other than a couple of injectors that went bad.

Toby
twistedcherokee is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
won't idle hot allbrand Troubleshooting for Road Glides 10 11-13-2012 06:53 PM
2009-2011 Vivid Black Road Glide Custom Paint Set $1999 v-rodder Classifieds Archive (3 months old+) 2 06-06-2011 07:28 AM
1999 ultra king tour pack off ultra EG used on a 2006 road glide?? kirkglide Aftermarket Accessories 2 05-30-2011 12:55 PM
1999 Road Glide FLTRI For Sale ctxrg Classifieds Archive (3 months old+) 0 05-05-2011 01:46 PM
'11 CVO Won't Idle Easy Glider Troubleshooting for Road Glides 1 11-27-2010 06:02 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome