Help with primary leak - Road Glide Forums
Engine Related Engine Builds and more for Road Glides

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 07-12-2016, 05:59 PM Thread Starter
Newbie
 
Join Date: Jul 2012
Location: Holland, MI
Posts: 30
Help with primary leak

Okay guys. Really need some help here. Before I roll this thing into traffic.

Bike is a 1992 ultra classic electra glide. I recently put a Ultima El Bruto 113 in it. New oring at the engine block and put it all together with Ultima high performance clutch. After about an hour ride. Starter went out. Pulled the outer primary, put a new starter in and reassembled. Took it for a ride and it blew oil all over. Pulled outer and inner primary replaced both seals ( Jackshaft and trans) put it back together. Today took it for a ride, oil leaking down again. Frustrated, I pulled the derby cover and there was pressure in there. Wth causes pressure in there? And if it's not supposed to have pressure is that what's causing the leak? It doesn't leak right away. I don't know which seal is leaking as I haven't taken it apart again. This is my father in law's bike and I just want the damn thing out of my garage now. I didn't have any of these issues on my road glide when I pulled the inner primary. Wth am I missing?

I need help. This thing is in the way of my cam install.

Sent from my SAMSUNG-SM-G935A using Tapatalk

Ride Hard or Go Home!!!!

U.S.A.F Vet. OIF/OEF 2007
lokitwitch04 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 07-12-2016, 06:48 PM
Life Member
 
Join Date: Jun 2012
Location: Pac NW
Posts: 4,105
Ultima s machine surfaces, seen their metallurgy do weird , but when right seem to run fine

Meaning sometimes gasket sets don't match per application always ck, cause of close tolerance, even overtightenin

Last edited by reds4; 07-13-2016 at 11:16 AM. Reason: Compression
reds4 is offline  
post #3 of 11 (permalink) Old 07-12-2016, 06:53 PM Thread Starter
Newbie
 
Join Date: Jul 2012
Location: Holland, MI
Posts: 30
Quote:
Originally Posted by reds4 View Post
Ultima s machine surfaces, seen their metallurgy do weird , but when right seem to run fine
What? The motor runs great. It's primary leak that I'm worried about. Lol

Sent from my SAMSUNG-SM-G935A using Tapatalk

Ride Hard or Go Home!!!!

U.S.A.F Vet. OIF/OEF 2007
lokitwitch04 is offline  
 
post #4 of 11 (permalink) Old 07-12-2016, 07:21 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,131
Garage
Are you sure it's primary oil ? If so, pretty easy to bungle up one of the spagetti seals.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
post #5 of 11 (permalink) Old 07-12-2016, 07:25 PM Thread Starter
Newbie
 
Join Date: Jul 2012
Location: Holland, MI
Posts: 30
Quote:
Originally Posted by Big_gary View Post
Are you sure it's primary oil ? If so, pretty easy to bungle up one of the spagetti seals.
Yeah it's the primary. It's getting on the belt on the primary side. Why would there be pressure in there? When I pulled the derby cover there was a lot of air that came out.

Sent from my SAMSUNG-SM-G935A using Tapatalk

Ride Hard or Go Home!!!!

U.S.A.F Vet. OIF/OEF 2007
lokitwitch04 is offline  
post #6 of 11 (permalink) Old 07-12-2016, 07:37 PM
Grey beard
 
lil chief's Avatar
 
Join Date: Jul 2015
Location: Nebraska
Posts: 973
Garage
Does that model have the pre bent rubber vent tube coming off the left side of the tranny near the primary? If so, check to make sure it's not clogged up.
Lil Chief

Famous Last Words: "Watch Me!"

2015 Denim Black RG, FM ss ceramic coated 2-1-2 pipe, White Bros Original E Series Mufflers, FM ac, PV Tuner
lil chief is offline  
post #7 of 11 (permalink) Old 07-12-2016, 07:46 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,131
Garage
Quote:
Originally Posted by lokitwitch04 View Post
Yeah it's the primary. It's getting on the belt on the primary side. Why would there be pressure in there? When I pulled the derby cover there was a lot of air that came out.

Sent from my SAMSUNG-SM-G935A using Tapatalk
They also vented through the push rod on the clutch into the Trans. Since you replaced the clutch, might be a good place to start.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
post #8 of 11 (permalink) Old 07-12-2016, 07:49 PM Thread Starter
Newbie
 
Join Date: Jul 2012
Location: Holland, MI
Posts: 30
Quote:
Originally Posted by Big_gary View Post
They also vented through the push rod on the clutch into the Trans. Since you replaced the clutch, might be a good place to start.
How do I check it? I adjusted the clutch per the manual. Turn it in til it touches and back off half turn, lock it down. Adjust cable to have 1/16" of play.

Sent from my SAMSUNG-SM-G935A using Tapatalk

Ride Hard or Go Home!!!!

U.S.A.F Vet. OIF/OEF 2007
lokitwitch04 is offline  
post #9 of 11 (permalink) Old 07-13-2016, 10:20 AM
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,528
You may have a bad crankshaft seal on the primary side of the engine.
The only way pressure could get in the primary is for the crankshaft seal to go bad and the crankcase pressure is leaking into the primary.
To check this you could get colored dye and put in the engine oil, you can get this dye at most top end auto parts stores. If the dye ends up in the primary fluid you know the crank seal is bad.
Also check the crankcase breathers and make sure they are functioning correctly.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
post #10 of 11 (permalink) Old 07-15-2016, 06:31 AM Thread Starter
Newbie
 
Join Date: Jul 2012
Location: Holland, MI
Posts: 30
I figured it out.

It was the seal that ultima uses on the clutch hub nut. It wasn't letting the primary vent. I pulled the seal out of it, put it back together and rode it. No leaks what so ever. I can't believe I've taken the inner primary apart 3 times because of that stupid seal.

Sent from my SAMSUNG-SM-G935A using Tapatalk

Ride Hard or Go Home!!!!

U.S.A.F Vet. OIF/OEF 2007
lokitwitch04 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Primary Leak Doug06rg *General Road Glide Discussions/Pictures 9 07-03-2016 12:34 AM
primary leak jprider4life Engine Related 15 07-02-2013 07:03 PM
Oil Leak? Primary Leak? shutzund Troubleshooting for Road Glides 4 06-04-2013 08:55 PM
primary oil leak doing trip of 500 mile is it ok jprider4life Tech Area 1 08-04-2012 11:50 PM
Primary oil leak need help. jprider4life *General Road Glide Discussions/Pictures 9 04-21-2012 12:02 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome