Engine died today - Road Glide Forums
Engine Related Engine Builds and more for Road Glides

 14Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 24 (permalink) Old 01-27-2018, 10:42 PM Thread Starter
Grey beard
 
1st Sgt's Avatar
 
Join Date: Apr 2011
Location: Florence, SC
Posts: 868
Engine died today

Enjoying great weather today and taking a ride - about 50 miles out my engine just died. No drama, no noise, it just quit like I had hit the kill switch (I didn't) Plenty of fuel and the bike would crank easily enough with the starter. Got a tow from Black Jack Harley Davidson and now just waiting to see what happened. 2nd time I've been broke down at the side of the road with this bike - maybe time to replace it.
Dickie likes this.

2019 Wicked Cherry RGU. And an even bigger smile than before.
1st Sgt is offline  
Sponsored Links
Advertisement
 
post #2 of 24 (permalink) Old 01-27-2018, 11:13 PM
Grey beard
 
PSUUUUU's Avatar
 
Join Date: Jun 2017
Location: Pennsylvania
Posts: 1,287
Garage
What year is it?

Sorry to hear brother. Thatís a terrible feeling.
1st Sgt likes this.
PSUUUUU is offline  
post #3 of 24 (permalink) Old 01-28-2018, 06:07 AM
Grey beard
 
Dragon Dude's Avatar
 
Join Date: Jul 2015
Location: Perdido Beach, Al.
Posts: 812
Garage
It might be a faulty fuel pump or maybe just the fuse.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2013 Road Glide vivid black, 14" JSR apes, Andrews 57h cams, S&S adjustable pushrods, Woods directional lifters
Dragon Dude is offline  
 
post #4 of 24 (permalink) Old 01-28-2018, 06:39 AM
Member
 
Join Date: Aug 2011
Location: south jersey
Posts: 365
Garage
we got today and 110 miles.stopped for lunch . no issues. get home.go out 15 minutes later to put the bike away, nothing, dead, no lights,nothing. damn ground wire was loose. bike sat for 6 weeks , started right up, rode all day and sitting in the drive way it doesnt start.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2011 RG ULTRA.
I RIDE. I FISH. HENCE THE THE ROD HOLDERS MOUNTED.
NOTHING LIKE DOING BOTH WHAT I ENJOY IN THE SAME DAY.
CPY84 is offline  
post #5 of 24 (permalink) Old 01-28-2018, 06:44 AM Thread Starter
Grey beard
 
1st Sgt's Avatar
 
Join Date: Apr 2011
Location: Florence, SC
Posts: 868
Quote:
Originally Posted by PSUUUUU View Post
What year is it?

Sorry to hear brother. Thatís a terrible feeling.
It's a 2011 RGU with 67k miles.

2019 Wicked Cherry RGU. And an even bigger smile than before.
1st Sgt is offline  
post #6 of 24 (permalink) Old 01-28-2018, 07:37 AM
Member
 
Join Date: Dec 2014
Location: The Free State
Posts: 337
Quote:
Originally Posted by 1st Sgt View Post
It's a 2011 RGU with 67k miles.
Hopefully they figure it out quickly and its something minor like a fuse or loose wire.
madmat likes this.

Hawkman
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2017 Lagauna Orange FLTRX, 2013 Candy Orange Road Glide Custom (traded), 2010 Ultra Classic (traded), 2004 Classic (sold to little brother), 1999, Classic (traded), 1999 Road King (best handling so far), 1994 Softail Custom (traded), 1974 Superglide (I miss her still).
Hawkman is offline  
post #7 of 24 (permalink) Old 01-28-2018, 10:24 AM
Newbie
 
bootlegger61's Avatar
 
Join Date: Nov 2011
Location: Dripping Springs, TX
Posts: 34
Garage
I had a 2011 RGU and had similar issue. Mine was a chaffed wire in the handlebar. I you pull the main fuse and plug it back in, and the bike starts, then its is probably electronic. It took me 3 visits to the dealer to figure out my problem. They finally replaced the wire harness in the handle bar and solved my problem.

Good luck.

Currently Riding a 2015 Road Glide Special
bootlegger61 is offline  
post #8 of 24 (permalink) Old 01-28-2018, 10:53 AM
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,528
Did you check for DTC's?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
post #9 of 24 (permalink) Old 01-28-2018, 11:43 AM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,040
Garage
Any mods on the bike ?
BlazingSaddle likes this.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
post #10 of 24 (permalink) Old 01-28-2018, 01:40 PM
Grey beard
 
BlazingSaddle's Avatar
 
Join Date: Aug 2014
Location: Florida
Posts: 927
Garage
If thereís any good news in all of this, itís the fact that it turns over. Usually itís something simple that takes a lot of time to chase down. Fuses are my first order of business. Hope itís s a simple and cheap fix for you. Keep us posted.
1st Sgt likes this.
BlazingSaddle is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine just died Magnum Troubleshooting for Road Glides 20 03-25-2014 05:43 PM
Engine died Singlebeam Troubleshooting for Road Glides 10 11-30-2013 05:32 PM
Stereo died today... MtnDewd Audio 23 09-23-2013 07:10 PM
Done for the season...engine died! akjeff *General Road Glide Discussions/Pictures 22 06-27-2013 09:33 PM
Battery died, now speakers not working!!!!!! schnid72 Audio 11 02-12-2011 07:33 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome