Single Ting from Primary with Throttle Twist - Road Glide Forums
Engine Related Engine Builds and more for Road Glides

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 01-10-2019, 10:04 AM Thread Starter
Hangaround
 
sethc1020's Avatar
 
Join Date: Jan 2019
Location: Indiana
Posts: 82
Single Ting from Primary with Throttle Twist

Hello all! New to the site and hopefully someone can help me out. I have a 2012 RGU with a little over 13K on it, just bought it last summer. I've noticed when the engine warms up I will hear a single metallic "ting" from inside the primary if I get on the throttle aggressively. It will do the same thing sitting in neutral or in gear riding down the road. Im thinking it may be the chain taping the inside of the case but not sure. If so could that be a tensioner issue possibly? Other than that it runs and rides great but that ting bothers me.

Thanks in advance!
sethc1020 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 01-10-2019, 10:44 AM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,040
Garage
Quote:
Originally Posted by sethc1020 View Post
Hello all! New to the site and hopefully someone can help me out. I have a 2012 RGU with a little over 13K on it, just bought it last summer. I've noticed when the engine warms up I will hear a single metallic "ting" from inside the primary if I get on the throttle aggressively. It will do the same thing sitting in neutral or in gear riding down the road. Im thinking it may be the chain taping the inside of the case but not sure. If so could that be a tensioner issue possibly? Other than that it runs and rides great but that ting bothers me.

Thanks in advance!
You really need to pull the outer cover and have a look and go from there. It could be a few things but probably is the compensator.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
post #3 of 3 (permalink) Old 01-10-2019, 11:53 AM Thread Starter
Hangaround
 
sethc1020's Avatar
 
Join Date: Jan 2019
Location: Indiana
Posts: 82
Thats what I was planing on doing to see if the chain has been hitting the cover. I don't think its the compensator because its just a single Ting with a good twist of the throttle. No problems at start up or when shutting off the bike, thats what makes me think it could be a tensioner.
sethc1020 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Will FP3 fix choppy throttle and sluggish response when passing MBigButt ECM/Fuel Management systems 9 07-21-2016 04:05 AM
How To Adjust Throttle Free Play And Why Motorcycle.com *General Road Glide Discussions/Pictures 1 03-14-2016 11:25 AM
Inner Primary Woes DED HD Troubleshooting for Road Glides 3 10-14-2015 06:57 PM
new twist grip efi throttle installed jaysandy Troubleshooting for Road Glides 16 04-28-2014 05:29 PM
New S&S Throttle Bodys Hillsidecycle.com Engine Related 10 08-28-2012 06:19 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome