Engine idle went up - Road Glide Forums
Engine Related Engine Builds and more for Road Glides

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 06-02-2019, 06:17 PM Thread Starter
Hangaround
 
Join Date: Mar 2012
Location: ct
Posts: 144
Engine idle went up

I got stuck in traffic for approx. 10 minutes, air temp was about 70. My engine idle started to increase and the clutch lever was not holding. I had to really press on the breaks to keep the bike from moving. If I let up on the break, the bike would move forward even with the clutch lever in. This is the 2nd time this has happened in traffic in 2 years. I shut the bike off for a couple of minutes, got out of the traffic (turned around) and the bike ran normal. Any thoughts guys? Thanks

2012 Road Glide Ultra
antant is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 06-02-2019, 06:38 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,040
Garage
Quote:
Originally Posted by antant View Post
I got stuck in traffic for approx. 10 minutes, air temp was about 70. My engine idle started to increase and the clutch lever was not holding. I had to really press on the breaks to keep the bike from moving. If I let up on the break, the bike would move forward even with the clutch lever in. This is the 2nd time this has happened in traffic in 2 years. I shut the bike off for a couple of minutes, got out of the traffic (turned around) and the bike ran normal. Any thoughts guys? Thanks
I'd change primary fluid and adjust the clutch ,then go from there. How many miles on it ?

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
post #3 of 7 (permalink) Old 06-02-2019, 08:15 PM
Member
 
FDR's RGC's Avatar
 
Join Date: Jan 2013
Posts: 545
^^^^^^^ primary fuild change^^^^^^^
FDR's RGC is offline  
 
post #4 of 7 (permalink) Old 06-04-2019, 07:57 AM Thread Starter
Hangaround
 
Join Date: Mar 2012
Location: ct
Posts: 144
I have 20,000 on the bike with approx. 3,000 on primary fluid. Thanks guys

2012 Road Glide Ultra
antant is offline  
post #5 of 7 (permalink) Old 06-04-2019, 10:38 AM
Life Member
 
Thermodyne's Avatar
 
Join Date: Jan 2014
Location: South Central PA
Posts: 1,756
Garage
Quote:
Originally Posted by antant View Post
I have 20,000 on the bike with approx. 3,000 on primary fluid. Thanks guys
The clutch drag is something that is probably indicating a secondary issue. You should check the fluid level in case its transfering. And you should check the plate lift on release, in case there is an issue with the hydraulics.

As for the high idle when sitting, that sounds like it went into idle temperature management. These M8's stay pretty smooth when EITMS activates (unlike the TC's), the idle stepping up is the most noticeable part of it. They will cycle into that pretty fast when sitting in traffic on a 70ish day. See if you notice a change in the exhaust tone next time it does it. And if you want to, you can turn it off and see if that stops it from recurring.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Thermodyne is offline  
post #6 of 7 (permalink) Old 06-04-2019, 11:04 AM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,040
Garage
Quote:
Originally Posted by Thermodyne View Post
The clutch drag is something that is probably indicating a secondary issue. You should check the fluid level in case its transfering. And you should check the plate lift on release, in case there is an issue with the hydraulics.

As for the high idle when sitting, that sounds like it went into idle temperature management. These M8's stay pretty smooth when EITMS activates (unlike the TC's), the idle stepping up is the most noticeable part of it. They will cycle into that pretty fast when sitting in traffic on a 70ish day. See if you notice a change in the exhaust tone next time it does it. And if you want to, you can turn it off and see if that stops it from recurring.
I assumed he had a 2012

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
post #7 of 7 (permalink) Old 06-04-2019, 11:56 AM
Life Member
 
Thermodyne's Avatar
 
Join Date: Jan 2014
Location: South Central PA
Posts: 1,756
Garage
Quote:
Originally Posted by Big_gary View Post
I assumed he had a 2012
You may be correct. I just assumed it was an M8 based on the two years comment and having heard this exact complaint a few times.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Thermodyne is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome