Medallion Gauge Issue - Road Glide Forums
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-27-2015, 05:07 PM Thread Starter
Hangaround
 
tlar1540's Avatar
 
Join Date: Aug 2013
Location: Sioux Falls, SD
Posts: 177
Garage
Medallion Gauge Issue

Hello to all.. I am having some issues with my Medallion gauges I have installed on a 2013 RGC. My gauges have been on the bike since new but this year when I took it out of storage the display just flashes "Medallion" and regardless of what I do, I can't get it to stop. I thought that maybe they needed to be reprogrammed but I can't get it to do anything but flash "Medallion". Has anyone ever ran into this before or know how to remedy this problem? I removed them and re-installed my OEM ones for now as I wanted to get out and ride. I tried to call Medallion on 3 separate occasions and got an answering machine. Left messages all 3 times & nobody has ever returned my call, so I'm asking the group that knows more about these than anyone else.
Thanks in advance for any help you can give me with this..
tlar1540 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-27-2015, 05:17 PM
Life Member
 
HogWild's Avatar
 
Join Date: Aug 2010
Location: Farmville, NC
Posts: 2,755
Garage
I've had some dealings with them and had to finally get ugly on a message. Called me right back. Customer service certainly isn't what it used to be. I had literally left messages over a few months. Try this and see if you have any luck. 616-847-3700 or [email protected]. Good Luck!!!

"No man is rich enough to buy back his past, so enjoy the moment"
HogWild is offline  
post #3 of 3 (permalink) Old 05-27-2015, 05:19 PM Thread Starter
Hangaround
 
tlar1540's Avatar
 
Join Date: Aug 2013
Location: Sioux Falls, SD
Posts: 177
Garage
Thanks for the information, I will call & send an e-mail right away & see what they tell me.. Your right, customer service really sucks these days...

Thanks again..


Quote:
Originally Posted by HogWild View Post
I've had some dealings with them and had to finally get ugly on a message. Called me right back. Customer service certainly isn't what it used to be. I had literally left messages over a few months. Try this and see if you have any luck. 616-847-3700 or [email protected]. Good Luck!!!
tlar1540 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
FS Medallion Just Black Bagger Gauge Setup 8960-00122-01 UltraNutZ Parts for Sale 3 05-15-2015 03:58 PM
Medallion Guages jedi *General Road Glide Discussions/Pictures 23 08-08-2013 12:37 PM
Rear Fender Medallion Removal Carbonfiberwingnut *General Road Glide Discussions/Pictures 7 04-24-2011 07:44 PM
FS 110 SE CVO Medallion for Ventilator A/C ScooterDog Classifieds Archive (3 months old+) 1 02-21-2011 10:39 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome