Compu-Fire charging system 40amp 3Phase - Road Glide Forums
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-31-2015, 06:09 PM Thread Starter
Grey beard
 
VikingRider's Avatar
 
Join Date: May 2014
Location: Oslo, Norway
Posts: 1,030
Compu-Fire charging system 40amp 3Phase

I have a 2001 CVO and at 27000 miles the charging system went haywire. I was a bit surprised as I expected it to last a little longer but given all the extra equipment I guess it was just a matter of when and not if. I hade to change both the stator and regulator.
The OEM charging kit was single phase so I got a 40 amp 3-phase charging system from Compu-Fire. It made a huge difference to say the least! I got a 14.2 volts regulator output from idle and up. The charging system provides 25 amps at idle and 40 amps steady at above 2500 RPM.
No more engine drag. Well, dog my cat - the old iron-horse feels like a pony again!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

FLTRSEI2
SE95-AN Stage 2-PCIII - SuperTrapp TDs-Kerker Stouts -KlockWerks Flare "12-Aquatic HU/J&M 7.5 ++ custom
VikingRider is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
iPhone 4S - Charging/Not Charging dinggus Audio 8 11-01-2013 09:25 AM
charging system issue crosen41 Troubleshooting for Road Glides 6 05-07-2013 02:03 PM
2002 FLTRI charging system test CraigB Troubleshooting for Road Glides 5 11-03-2012 12:18 AM
USB Charging Mount/System GRTSHRK Do-IT-Yourself 4 10-07-2012 07:52 AM
Electrical System Not Charging jimmyray11349 Troubleshooting for Road Glides 3 03-23-2012 08:31 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome