sluggin - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-29-2011, 06:01 PM Thread Starter
Newbie
 
firerodder's Avatar
 
Join Date: Jan 2011
Location: Athens, GA.
Posts: 28
sluggin

Okay fellow RG-ers... I'm back again with yet another question that I'd like your input on.

Lately when ridding if I get in the 3200+ RPM range it feels as though I'm trailing the rear brake. I have great lower end power and it doesn't seem to be sluggish when I'm off idle to the stated range. This has just started, but I'd say it's been going on for three days now. I ride every day and use my bike as my primary transportation, so it doesn't sit in the garage for weeks and just come out for the weekend. I've got 14K rolled on it now and it's a '07. The cruise seems to be screwing up now too and turning itself off from time to time. I'm guessing it might be related, but who the hell knows. Anyway, I'm looking for suggestions or possible problems, so let me hear whatcha got. Thanks to all ahead of time, ride safe!
firerodder is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome