oil pressure! - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 08-29-2011, 07:44 PM Thread Starter
Newbie
 
Blackrg's Avatar
 
Join Date: Sep 2010
Location: Indy
Posts: 43
oil pressure!

No oil pressure showing on gauge, I do have oil pressure though. Just installed Dakota digitals, set it for correct sensor too. Called them.... no help.
I took off the fairing again and checked everything then installed the oem gauge and still nothing.
Thought maybe bad sending unit, bought that installed and no go! Anything else to check I dont know about?

2010 FLTRX Fuel Moto 107, Heavy Breather,SE tuner,RC components 21 in front wheel, single disc matching rotor, PM calipers,Progressive monotube front, Dakota digital, Hogg Chopps, Sancho wings, 10 inch mini apes, Bannana boards. V&H true duals and boomcans.Don't pick a fight with an old man. If he is too old to fight, he'll just kill you.
Blackrg is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 08-29-2011, 10:50 PM
Life Member
 
CHAINSAW's Avatar
 
Join Date: Sep 2009
Location: SW Kansas - Hugoton
Posts: 8,225
How are you sure you have oil pressure?






For a wounded man shall say to his assailant,
'If I live, I will kill you. If I die, You are forgiven.'
Such is the rule of honor.


CHAINSAW is offline  
post #3 of 11 (permalink) Old 08-29-2011, 11:16 PM
Member
 
DemonCity's Avatar
 
Join Date: Jul 2010
Location: Fresno
Posts: 539
Quote:
Originally Posted by CHAINSAW View Post
How are you sure you have oil pressure?
Bikes running! Lol!!!

1%DFFD1%
DemonCity is offline  
 
post #4 of 11 (permalink) Old 08-29-2011, 11:44 PM Thread Starter
Newbie
 
Blackrg's Avatar
 
Join Date: Sep 2010
Location: Indy
Posts: 43
Quote:
Originally Posted by DemonCity View Post
Bikes running! Lol!!!
Well yes it is running and it runs fine 200 -230 around town today.
It runs the same sounds the same no issues there so I'm assuming I have oil pressure . Since I replaced the sender thought maybe i was missing something.I'm guessing some sort of wiring issue just thought I'd ask.

2010 FLTRX Fuel Moto 107, Heavy Breather,SE tuner,RC components 21 in front wheel, single disc matching rotor, PM calipers,Progressive monotube front, Dakota digital, Hogg Chopps, Sancho wings, 10 inch mini apes, Bannana boards. V&H true duals and boomcans.Don't pick a fight with an old man. If he is too old to fight, he'll just kill you.
Blackrg is offline  
post #5 of 11 (permalink) Old 08-30-2011, 07:46 AM
Member
 
EdY39's Avatar
 
Join Date: Jan 2011
Location: Kokomo, MS
Posts: 505
If the oil pressure light is not coming on, the problem has to be with the Dakota gauge. Install the stock gauge back in and see if it shows pressure.

Ed
2002 RoadGlide
DPCM, USN (Retired)
EdY39 is offline  
post #6 of 11 (permalink) Old 08-30-2011, 09:37 AM
Prospect
 
Join Date: Feb 2010
Location: Raleigh N.C.
Posts: 251
bad ground ?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ROADEAGLE is offline  
post #7 of 11 (permalink) Old 08-30-2011, 01:42 PM
Hangaround
 
Join Date: May 2011
Location: Columbus, Montana
Posts: 70
Quote:
Originally Posted by ROADEAGLE View Post
bad ground ?
Many electrical problems seem to lead to a bad ground.
Seadog is offline  
post #8 of 11 (permalink) Old 08-30-2011, 02:59 PM
Prospect
 
Join Date: Dec 2010
Location: Peoria, IL
Posts: 202
Wow.

I guess you should check continuity from the sending unit to the gauge. No power. Disconnected both ends. If it's zero ohms try and figure out where the circuit gets ground. It would be the engine on that end. Separate wire on the other end, inside all that plastic, going to a ground somewhere.

Good Luck

Edy39 - He DID cross check it with the oem gauge... No joy.
FGOWI is offline  
post #9 of 11 (permalink) Old 08-31-2011, 05:33 PM Thread Starter
Newbie
 
Blackrg's Avatar
 
Join Date: Sep 2010
Location: Indy
Posts: 43
Well it seems if you switch the connectors it works fine. I had the volt gauge connected to the oil pressure . Numbnuts I guess.

2010 FLTRX Fuel Moto 107, Heavy Breather,SE tuner,RC components 21 in front wheel, single disc matching rotor, PM calipers,Progressive monotube front, Dakota digital, Hogg Chopps, Sancho wings, 10 inch mini apes, Bannana boards. V&H true duals and boomcans.Don't pick a fight with an old man. If he is too old to fight, he'll just kill you.
Blackrg is offline  
post #10 of 11 (permalink) Old 08-31-2011, 06:00 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,136
Garage
For you folks who don't do this type of work for a living I have one tip .... Label your parts and wiring when removing .

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
High Oil Pressure and High Oil Temps ironmark Troubleshooting for Road Glides 17 12-09-2012 10:44 AM
use of a oil pressure gauge for air psi??? bigeyed76 Equipment-RG 9 03-11-2012 11:31 PM
oil pressure question dennisnyhc *General Road Glide Discussions/Pictures 5 03-18-2011 09:00 AM
Oil Pressure dhhen Troubleshooting for Road Glides 11 12-07-2010 11:50 PM
Oil pressure gauge 2010fltrx Troubleshooting for Road Glides 1 08-16-2010 04:09 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome