Batt & Low Fuel light came on WTF - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-17-2011, 07:54 PM Thread Starter
Hangaround
 
Cotton Hill's Avatar
 
Join Date: Oct 2009
Location: Phoenix, AZ/Canton, OH
Posts: 133
Batt & Low Fuel light came on WTF

This morning going to work, about 3 minutes into the ride my This morning going to work, about 3 minutes into the ride my Batt & Low Fuel light came (over half full) on looked at the Volt meter it showed about 11.75. I slowed an turned around then the idiot lights went off so I turned around again and rode to work 50 Mi.and everything seems fine. Was that a warning that my stator or ECM is going bad?

Last edited by Cotton Hill; 10-17-2011 at 07:56 PM.
Cotton Hill is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-17-2011, 08:50 PM
Life Member
 
Triplej's Avatar
 
Join Date: Oct 2011
Location: Nevada, TX
Posts: 5,434
It could be as simple as a loose battery cable or bad/corroded electrical connection, etc. I would start with checking you battery cable ends (both ends of both cables) for good connections and then checking to see if you have any stored Diagnostic Codes.
Triplej is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can I use my batt tender lead to power heated gloves? kyle31490 *General Road Glide Discussions/Pictures 10 04-10-2015 12:36 PM
Engine light came on and speedometer went dead for the second time in 2 months Clean&Sober Troubleshooting for Road Glides 5 12-11-2013 04:14 AM
WTF spring came off Jiffy stand ameleo *General Road Glide Discussions/Pictures 16 10-26-2012 02:36 PM
engine light came on jprider4life Troubleshooting for Road Glides 0 06-01-2012 12:16 PM
Engine Light and Batt Light come on at same time Hintontm Troubleshooting for Road Glides 8 05-12-2012 07:37 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome