Speedometer Issue - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 07-25-2014, 11:04 AM Thread Starter
Newbie
 
Join Date: Jul 2014
Posts: 4
Speedometer Issue

Can someone point me in the right direction here? My speedometer went nuts reading all over the place. I assume the crank position sensor is the sensor I need to clean or replace?
First, is that correct? And second is this the sensor on the front behind the oil filter?
Bike is an 02 88ci
Thanks
Quipster is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 07-25-2014, 04:12 PM
Newbie
 
Join Date: Jun 2014
Location: Littleton CO
Posts: 24
It's the speed sensor in the transmission that you need to clean and check. It is on the right side of the bike on top of transmission below the starter.
RebelRider is offline  
post #3 of 6 (permalink) Old 07-25-2014, 04:37 PM
Member
 
Join Date: Feb 2010
Location: Finger Lakes, Upstate NY
Posts: 740
Speed sensor

If your cruise doesn't work, turn signals don't reset after a turn, it is your speed sensor. I cleaned mine and it didn't help. Replace it. Mine is a 2000 SERG. Works great for the last 15k
Jayray is offline  
 
post #4 of 6 (permalink) Old 07-25-2014, 04:43 PM
Grey beard
 
Clean&Sober's Avatar
 
Join Date: Apr 2013
Location: Alabama
Posts: 1,062
Was it raining. I had 2 speed sensors replace the last time they used grease and I have not had a problem in over 5k miles.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2013 FLTRX Custom, 16" back Hill Country apes. Full header Python Momba pipes with a stage1 kit. Boom Speakers. 11" gun smoke Windvest windshield
Clean&Sober is offline  
post #5 of 6 (permalink) Old 07-28-2014, 04:02 PM Thread Starter
Newbie
 
Join Date: Jul 2014
Posts: 4
Thanks everyone. I appreciate the quick responses. New to the forum and am a little overwhelmed with all the good information.

By the way, yes it know it is the speed sensor for sure that controls signals, radio volume, and definitely not least the cruise control. The speedo just didn't quit. It starting fluctuating BIG TIME! I was kicked back relaxing with the cruise set and it went berserk! Throttle wide open, then off, then wide open, etc. Scared the crap out of me first, then when I grabbed the brake and realized what was happening I just had to laugh. I didn't realize what a wimp I have become until I had to ride the last 600 or so miles with no cruise and I can never remember to cancel my turn signal!
I guess technology ain't so bad! lol
Quipster is offline  
post #6 of 6 (permalink) Old 07-28-2014, 04:06 PM Thread Starter
Newbie
 
Join Date: Jul 2014
Posts: 4
Thanks. That's what I thought. I stopped at the local dealer and they said no, it's the crankshaft position sensor. I didn't buy it. Just didn't sound right to me.
Quipster is offline  
Reply

Tags
sensor , speedometer

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing LEDs on speedometer SGT_Rob *General Road Glide Discussions/Pictures 7 02-04-2012 11:39 PM
speedometer and tach myfxr93 Wanted! (Buy or Trade) 3 12-31-2011 02:25 AM
Speedometer / odometer ? TearlessTom *General Road Glide Discussions/Pictures 6 08-07-2011 01:42 PM
Speedometer accuracy Govdog76 *General Road Glide Discussions/Pictures 11 02-22-2011 11:07 PM
Wtb-silver faced speedometer JPROADGLIDE Classifieds Archive (3 months old+) 3 02-15-2011 12:59 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome