Radio Static After Load Equalizer Install - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-26-2014, 11:16 PM Thread Starter
Newbie
 
Join Date: Jan 2014
Location: Connecticut
Posts: 27
Post Radio Static After Load Equalizer Install

I installed custom Dynamics LED front and rear directionals and the required custom dynamics load equalizer. Since installing the load equalizer, when I use the turn signals, I get static on the radio, on and off to the same pattern as the blinking turn signals. Called my local Harley shop and they couldn't help me. Any ideas on how to fix this issue? Only happens when playing the radio, does not happen with Cd's.
Luis FLTRX-13 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Custom Dynamics Load Equalizer Radio Interference Luis FLTRX-13 Lighting 4 08-06-2014 03:35 PM
Static in radio after Daymaker install litespeed Lighting 0 07-21-2013 08:54 PM
Badlands load equalizer bddslayer1 Lighting 0 11-29-2012 03:56 PM
Load Equalizer?? Bobohole68 Lighting 9 07-24-2012 03:31 PM
Trailer, Hitch and load equalizer for sale Redfish-Joe Classifieds Archive (3 months old+) 5 12-29-2010 06:55 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome