Battery under load - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-27-2014, 11:06 PM Thread Starter
Newbie
 
Join Date: Aug 2013
Location: Vancouver BC Canada
Posts: 10
Battery under load

I drained my battery down to zero for the second time this year....yeah yeah I know i'm a dumbass. I put it on the trickle charger both times, the second time, after charging overnight I thought I was in the clear (12.5 volts). I tried to start it and ther was a 1 second pause and then it turned over. After a few longer rides the pause is more pronounced and it's barely turning it over. I did a meter reading when I got home and it is 12.5 when no load, I turn the ignition on and it goes down to 11.5 and then when I try to start ithe bike it drops down to 6.6 for a split second. Everything I could find out about batteries tells me that it shouldn't drop below 9.9 when tryng to start the bike. Has any checked their battery while trying to start it and the big question.....is my battery pooched?

Your word is your bond.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
bullet is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-28-2014, 12:06 AM
Hangaround
 
Lotto's Avatar
 
Join Date: Oct 2012
Posts: 72
Just went thru same issue........ITS TOAST

Sent from Motorcycle.com Free App
Lotto is offline  
post #3 of 3 (permalink) Old 07-28-2014, 12:16 AM Thread Starter
Newbie
 
Join Date: Aug 2013
Location: Vancouver BC Canada
Posts: 10
That's what I thought, Thanks Lotto

Your word is your bond.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
bullet is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Tranny slow to shift into 6th gear under load Jester Troubleshooting for Road Glides 19 08-07-2017 05:45 PM
103 acting strange under heat/load cookie114 Engine Related 11 06-14-2016 12:55 AM
USB install (under tank) to battery? jumpmasterjay *General Road Glide Discussions/Pictures 6 03-30-2013 12:45 AM
Buzzing/Humming noise under light load TheDon81 Troubleshooting for Road Glides 1 05-08-2012 01:17 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome