Battery - Check Engine Replicated 3 times - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 08-14-2014, 08:48 PM Thread Starter
Life Member
 
Paul's Road Glide's Avatar
 
Join Date: Mar 2012
Location: Katy, TX
Posts: 2,217
Garage
Battery - Check Engine Replicated 3 times

Ok guys, need your input.

In three occasions starting yesterday morning and twice today in the evening....

Bike turns on fine but after a few minutes of rolling, my check engine light and battery light come on. I check the volt meter on the dash as I'm riding at it reads something like 11 give or take. After 15-20 minutes in each of the three occurences the volt meter then goes back to normal around 13.5 or so and the lights turn off.

I currently just bought a brand new battery. Only about 1 month old

VR was replaced about 25K miles ago

I pulled the derby inspection cover and looked for that infamous burnt wire smell from the stator but I guess it kinda smells like it (scratching head) but then again is it just the smell of hot synthetic oil. I dunno.

I guess where should I start?

Right now battery is charging on a tender and will then read off that.

"Just put that hammer down and give it hell" -Jerry Reed.
Paul's Road Glide is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 08-14-2014, 10:20 PM
Administrator
 
JacktheBagger's Avatar
 
Join Date: Apr 2010
Location: Bama
Posts: 9,568
Garage
sounds like the stator , when mine went out , the voltage dropped to under 12 momentarily twice that I know of .. My battery died a couple weeks later

JtB

So Many Highways So Little Time
2011 Ultra
JacktheBagger is online now  
post #3 of 15 (permalink) Old 08-14-2014, 11:20 PM
Gray Beard
 
lundboy1's Avatar
 
Join Date: Jan 2013
Location: Eastern Idaho
Posts: 1,521
Garage
I'd say start simple with connectors pinched wires corrosion etc. then have the vr checked, final measure is stator


Sent from Motorcycle.com Free App

" wishin' my knees were in the breeze!!!"
lundboy1 is offline  
 
post #4 of 15 (permalink) Old 08-15-2014, 10:06 AM Thread Starter
Life Member
 
Paul's Road Glide's Avatar
 
Join Date: Mar 2012
Location: Katy, TX
Posts: 2,217
Garage
going to be doing the serious diagnostics this evening. I needed to let the battery charge overnight so I can test accurately.

I guess I don't care what it is, I just want to fix the right part the first time.

"Just put that hammer down and give it hell" -Jerry Reed.
Paul's Road Glide is offline  
post #5 of 15 (permalink) Old 08-15-2014, 12:14 PM Thread Starter
Life Member
 
Paul's Road Glide's Avatar
 
Join Date: Mar 2012
Location: Katy, TX
Posts: 2,217
Garage
Does anyone have the link or now the post that someone made on here about what procedures to check the charging system?

I found yesterday but now can't seem to find it.

Thanks.

"Just put that hammer down and give it hell" -Jerry Reed.
Paul's Road Glide is offline  
post #6 of 15 (permalink) Old 08-15-2014, 06:18 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,133
Garage
Quote:
Originally Posted by Paul's Road Glide View Post
Does anyone have the link or now the post that someone made on here about what procedures to check the charging system?

I found yesterday but now can't seem to find it.

Thanks.
http://blog.jpcycles.com/step-by-ste...arging-system/

this should do ya along with specs of the 2010 system.
Attached Images
File Type: jpg 20140815_181627.jpg (84.1 KB, 26 views)

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
post #7 of 15 (permalink) Old 08-15-2014, 09:49 PM Thread Starter
Life Member
 
Paul's Road Glide's Avatar
 
Join Date: Mar 2012
Location: Katy, TX
Posts: 2,217
Garage
Ok this is what I have done and found. thanks for the specs that helped a lot.

charged battery and is good at 12.8

unplugged stator and checked all three connections in the 4 phase mode. they checked out to specs above. that means stator and rotor are good.

also used a light meter and grounded it properly, turned bike on and check terminals at stator. light never came one. notes indicate that is a good thing.

My assumption is the VR is gone bad, but I couldn't find notes on how to check the VR. (nevermind. I see notes on JP cycles website).

Did I miss anything?

"Just put that hammer down and give it hell" -Jerry Reed.
Paul's Road Glide is offline  
post #8 of 15 (permalink) Old 08-15-2014, 11:33 PM
Life Member
 
Join Date: Feb 2012
Location: Los Angeles CA
Posts: 3,115
Had the same thing which started to happen more and more frequently. All tested fine. Took it to the dealer under warranty and the stator and voltage regulator were replaced. The plug between the two had some burnt points in it. It's been fine the last 4000 miles.
HogPro is offline  
post #9 of 15 (permalink) Old 08-16-2014, 08:40 AM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,133
Garage
The VR can be very temperamental when going bad.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
post #10 of 15 (permalink) Old 08-19-2014, 03:13 PM
Newbie
 
Join Date: Feb 2014
Posts: 1
My bike is currently doing the same thing. Did it end up to be the VR? I guess I'll be running tests too. I'm right at 10k, so my primary oil is due anyway.
NHFLTRX is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Check Engine & Battery Lights?? George W Troubleshooting for Road Glides 3 08-11-2016 02:35 AM
Check Engine Light and Battery Light following Jackpot 2-1-2 install PearlBlueUltra Troubleshooting for Road Glides 9 06-15-2014 04:59 PM
check engine and battery light drmudd Troubleshooting for Road Glides 11 04-20-2013 02:08 PM
engine stalls and also idle jumps to 2K at times Ahh-Ho RRMC Troubleshooting for Road Glides 12 01-04-2013 02:28 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome