ECM plug wont lock - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 08-17-2014, 08:48 PM Thread Starter
Member
 
hoosierboarder's Avatar
 
Join Date: Jun 2012
Location: Indianapolis,IN
Posts: 448
ECM plug wont lock

I had a P1511 code yesterday. Found moisture in the ECM plug where it connects to the throttle body. Got the code cleared & bike ran fine. When I got home, I took the plug off to clean it & put some dielectric grease in. Now the plug won't lock. No pins bent, nothing seems to be interfering, as I can push the plug completely on. the tab is not broken, but won't lock. It doesn't pull off real easy but does pull off. Any suggestions?

'09 Road Glide
hoosierboarder is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 08-17-2014, 10:00 PM
Member
 
RoadGlideGary's Avatar
 
Join Date: Feb 2011
Location: Golden Colorado
Posts: 462
Unless there is something interfering (pin bent or mis-aligned) it should seat fine. Pull apart and check pins and see if anything is stuck in either boot. Should snap and lock in place with solid feel.

08' FLTR - Customized!!! (Check my Albums)
05' SuperGlideCustom - sold
RoadGlideGary is offline  
post #3 of 4 (permalink) Old 08-17-2014, 10:53 PM
Grey beard
 
Join Date: Jan 2013
Location: The Redneck Riviera
Posts: 1,390
Maybe too much grease?? A LiL Dab, I'l Do 'Ya...

"I've read dozens of books about heros and crooks, and learned much from both of their styles"

'09 SERG 117/DD7 "THE SHORT BUS"
HeatWave is offline  
 
post #4 of 4 (permalink) Old 08-18-2014, 02:14 PM Thread Starter
Member
 
hoosierboarder's Avatar
 
Join Date: Jun 2012
Location: Indianapolis,IN
Posts: 448
Found the problem. The locking tab on the TCA plug (don't know why I said ECM) where it connects to the induction module was cracked. $13 got me a new connector housing & we're back on the road.

'09 Road Glide
hoosierboarder is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
SE Phat Plug Wires or OEM Plug Wires wevsspot *General Road Glide Discussions/Pictures 31 07-07-2017 11:17 AM
Tour Pack Lock W/Flat Key Lock. Bill-99RG *General Road Glide Discussions/Pictures 3 01-15-2015 02:16 AM
Who knows what pin in ECM plug is for cruise milkman48 ECM/Fuel Management systems 1 03-31-2014 09:33 PM
changed bars now bike wont start NO4NBIKES Controls & Handlebars 4 01-02-2012 11:06 AM
wont start The instigator Road Glide Specific Discussions 8 03-24-2011 10:20 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome