Electrical issue - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 09-04-2014, 08:07 PM Thread Starter
Hangaround
 
Citykid's Avatar
 
Join Date: Jun 2012
Location: Suffolk County, NY
Posts: 178
Electrical issue

Coming home tonight I notice that while in sixth gear, the 6th gear light isn't on. Then the light & engine light come on. Uh oh. I look at my gauges and see my volts gauge pinned at 16! S**t. I slow down and the volts drop to 14 and the bike works again. But any hard acceleration and it happens. Again and again this happened as I limped home.

Before this happened I was white lining it in heavy NY traffic. Couldn't tell you what my gauges were reading as I had no time to look at them.

Anyone know what it means when the 6th light goes out, then come on with the engine light? I know it's concerning electricity, but that's about it.
Citykid is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 09-04-2014, 10:39 PM
Member
 
Methos1979's Avatar
 
Join Date: Sep 2012
Location: Seacoast, NH
Posts: 463
I had this happen a few weeks ago. A little research here showed others having this issue and it ended up being a bad voltage regulator - a 'known' issue that is covered under warranty. I went in and had it looked at and they replaced the entire voltage regular and associated parts. While there they also diagnosed a funny noise in the primary (which I didn't even hear/notice) and they replaced that as well, also under warranty, also a known issue. My warranty is up in two weeks - or it was going to be... I just reupped if for two more years!

2013 Road Glide Custom CVO in Roman Gold/Burnt Emerald, Le Pera Maverick, Vance & Hines Power Duals, SERT, MadStad 13", Kury ISO grips & Scythe mirrors.
Methos1979 is offline  
post #3 of 4 (permalink) Old 09-04-2014, 11:58 PM
Life Member
 
rlaf75's Avatar
 
Join Date: Sep 2011
Location: East Hartford CT
Posts: 7,194
There has been issues with the voltage regulators. I believe there was a recall on them or at least a service bulletin about it. Let a dealer run your VIN to see if yours was one of the bikes involved

09 Mirage Orange Pearl

Some people just need a high-five. In the head. With a chair
rlaf75 is offline  
 
post #4 of 4 (permalink) Old 09-05-2014, 09:49 AM Thread Starter
Hangaround
 
Citykid's Avatar
 
Join Date: Jun 2012
Location: Suffolk County, NY
Posts: 178
Spoke with Harley. The recall is now expired. But my bike wasn't in it anyway. They think the same as above that it is the regulator. I go tomorrow.
If I ride slow, which is very hard to do, I should be okay to make it to the stealership. Thanks for the info.
Citykid is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Head unit or other electrical issue? L-Premo *General Road Glide Discussions/Pictures 1 10-30-2013 11:02 PM
Electrical possible sensor issue...??? Johnzz1420 *General Road Glide Discussions/Pictures 5 08-05-2013 05:31 PM
2012 RoadGlide Ultra Electrical Issue H-Town Defender Troubleshooting for Road Glides 1 07-01-2012 12:38 PM
Electrical issue ? tcon287 *General Road Glide Discussions/Pictures 1 09-05-2011 10:51 PM
Electrical issue with horn and left blinker mtmy2k Troubleshooting for Road Glides 3 09-03-2011 11:56 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome