lost radio horn and directionals - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 09-28-2014, 09:12 PM Thread Starter
Newbie
 
Join Date: Mar 2014
Posts: 15
lost radio horn and directionals

hey, on a great ride through Connecticut today, I suddenly lost the horn, directionals, and radio on my '07 fltr.(57,000 miles) the bike ran fine, had head and tail lights, volt gauge read 14. stopped for a great burger at Plan B, went out, fired it up, everything worked fine all the way home. only thing I can think is I was charging my phone through the cigar lighter but I've always done that. any ideas? thanks
ckl2007 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 09-28-2014, 10:03 PM
Life Member
 
rlaf75's Avatar
 
Join Date: Sep 2011
Location: East Hartford CT
Posts: 7,194
I'd start by checking the fuses with a test light. Always start with the basics then go from there. Where in CT were you?

09 Mirage Orange Pearl

Some people just need a high-five. In the head. With a chair
rlaf75 is offline  
post #3 of 5 (permalink) Old 09-29-2014, 07:07 PM
Administrator
 
Stray Mutt's Avatar
 
Join Date: Nov 2010
Location: The OC
Posts: 2,863
I had similar symptoms on the way home from SW IV. The necessaries (head lights and tail lights) stayed on, but the luxuries (radio, turn signals, cruise) were gone. My fuse was blown and the replacement blew immediately too, so I knew I had a short (which turned out to be a blown amp). Could be a temporary short/maybe thermal growth issue. I know that's not a whole lot of help, but a good circuits guy should be able to diagnose it.

What if the Hokey-Pokey really is what it's all about?
Stray Mutt is offline  
 
post #4 of 5 (permalink) Old 09-29-2014, 08:47 PM
Life Member
 
Join Date: Jun 2012
Location: Pac NW
Posts: 4,105
Funny how you don't see "how to" do a shunt on HD's, must be from the times we had a master link tugged off our boots and an disposabe blade..
reds4 is offline  
post #5 of 5 (permalink) Old 09-30-2014, 04:39 PM Thread Starter
Newbie
 
Join Date: Mar 2014
Posts: 15
lost horn raio directionals

Maybe I should have been more specific. When I started the bike back up, everything worked normally. The horn, radio, and directional. Rode to work the next day, no issues. That great burger at Plan B Burger Bar in Glastonbury. From r.i., went 82 to 85 to 94. tok 66 to 32 to 14 home. Nice ride
ckl2007 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
tour pack directionals zapshd Lighting 3 08-07-2018 01:56 AM
Help 2001 Road glide CVO Directionals Bad Harley Troubleshooting for Road Glides 2 05-31-2013 02:36 PM
Right side directionals not working crazyredneck Do-IT-Yourself 2 07-03-2012 10:01 PM
Well I went and lost my mind today......... Fire-Medic *General Road Glide Discussions/Pictures 69 04-13-2012 09:08 PM
PIAA headlights and Custom Dynamic directionals ybnorml Lighting 6 06-28-2011 12:49 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome