Thundermax proublems ? - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 10-03-2014, 11:49 AM Thread Starter
Newbie
 
Join Date: Jan 2013
Location: Phelan ca
Posts: 29
Thundermax proublems ?

I have a 2012 road glide with a big sucker intake, rineheart 2-1, and a powercomander 5. I bought a thundermax, installed it, it worked fine for about 3 months. Then the speedometer started only working about 2/3 the time , so I got ahold of thundermax , they after a time of sending data to them replaced the emc. Got the new one installed it does the same thing. I talked to Chris at cyclesolutions who I bought it from, he said about 9 or 10 bikes out of a 100 have problems with thundermax . He told me to clean the fuses use dielectric grease. Put more dielectric grease on the Harley plug that installs into the emc all of this I have done. It still has the same problem. Keep in mind I put the Pc-5 back on and everything works fine. Please help
craig demel is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 10-03-2014, 01:16 PM
Shark of the Month December 2013
 
Bluchevypick's Avatar
 
Join Date: Mar 2012
Location: Texarkana, Ar
Posts: 679
The best advise i can give you is to contact Thundermax once again. They have really good tech support and will get it resolved.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2012 RGU, Custom paint, stage 4 w/woods 777 cams, bassani road rage, CM Legacy ES 21/18 combo, 1 PBR amp and 1 RS-400 with 6 ZX series 6.5 speakers and a whole lot more.
Bluchevypick is offline  
post #3 of 5 (permalink) Old 10-03-2014, 01:30 PM
Hangaround
 
eme56's Avatar
 
Join Date: Aug 2012
Location: St. Louis, MO
Posts: 137
I had the same thing happen last summer - 3 times in one week. Like you, I cleaned the ECM plug and fuses and added a little dielectric grease. I also cleaned and greased the plugs on the back of the speedometer and tach. It has not done it since. You might give that a try.

2005 FLTRI Black Cherry, 95" Big Bore, Thundermax w/Auto Tune, V&H Dresser Duals w/Klock Werks SS, Andrews 26 Cams, SE Stage 1 intake, SE OD/6 Speed, Wards FCS cooling fans, Krome Werks Stretch Heritage +2 bars, Progressive Monotubes, 444's, & Touring Link, Michelin Commander II's, 14.5" Madstad, Lowers with Classic Motorcycle Vents, detachable King Tour Pack, Daymakers
eme56 is offline  
 
post #4 of 5 (permalink) Old 10-03-2014, 04:53 PM Thread Starter
Newbie
 
Join Date: Jan 2013
Location: Phelan ca
Posts: 29
thundermax problems

Thanks Hanground, Ill try the diec grease on the speedo plug &see what happens
craig demel is offline  
post #5 of 5 (permalink) Old 10-04-2014, 11:18 AM
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,528
Did you set the speedometer calibration when you installed the T-Max tuner. There are different settings for the speedometer and the setting on your base map may be the incorrect setting.
Go to basic settings and click on speedometer and check.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Thundermax TBW MakeARunMike ECM/Fuel Management systems 15 06-01-2011 11:07 AM
Thundermax on a stock 2010 RGC pab ECM/Fuel Management systems 18 12-22-2010 05:25 AM
Thundermax impression Rowdy ECM/Fuel Management systems 9 11-23-2010 10:27 PM
thundermax TBW roadgliderick ECM/Fuel Management systems 0 11-23-2010 01:36 AM
Zipper Thundermax Ranger58 ECM/Fuel Management systems 12 11-19-2010 11:26 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome