Ignition switch SOS - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 10-05-2014, 08:51 PM Thread Starter
Hangaround
 
Join Date: Sep 2014
Location: Michigan
Posts: 87
Unhappy Ignition switch SOS

Just picked up a 2015 Road Glide special, first touring bike. Today I was doing a little cleaning after a nice ride and decided to roll the bars forward a bit. I removed the ignition switch with no issue per the videos on the net and adjusted the bars. I put everything back together without issue (so I thought). I must have misaligned some of the internal lock tumblers or put the switch down too far.
1. Ignition turned to lock and bars are not locking
2. pressing the detent on the bottom of the switch no longer allows it to slide out of the barrel.
3. Looking at a friends new glide I see that his switch assembly doesn't sit down as low as mine

If I have the switch in the lock position I have to push in the detent on the bottom to get the assembly to rotate to the other positions otherwise its like its locked.

How do I reverse my screw up without taking it to the dealer?
mray81 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 10-05-2014, 09:37 PM
Member
 
Join Date: Jun 2013
Location: Southern WV
Posts: 688
Garage
Sounds like the tab on the bottom that is supposed to be in the fork lock notch is below it. The wedge that comes out for the detent is not in the right groove. Have to push the detent and rotate the switch until the ignition notch (upper tab) and the fork lock notch (lower tab) align again. Had the same issue last time I had the switch out of mine and took a little patience to get it back out and then back in right.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
DuraGlide is offline  
post #3 of 10 (permalink) Old 10-06-2014, 09:36 AM Thread Starter
Hangaround
 
Join Date: Sep 2014
Location: Michigan
Posts: 87
that was my thought as well. tried rotating it around and lifting it for a while last night with no luck. Had to walk away. I'll try again tonight.
mray81 is offline  
 
post #4 of 10 (permalink) Old 10-06-2014, 05:53 PM Thread Starter
Hangaround
 
Join Date: Sep 2014
Location: Michigan
Posts: 87
Ok looking at it now the detent is in the lock groove when ignition is turned to lock position but the whole knob is too low to let the detent slide around in the groove. Maybe tumblers are out of sync holding the assembly down too low????
Anyone have any suggestions?
mray81 is offline  
post #5 of 10 (permalink) Old 10-06-2014, 06:30 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,128
Garage
Yea, just keep messing with it. You will get it. It always takes me a few times too. Its all about alignment.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
post #6 of 10 (permalink) Old 10-06-2014, 08:06 PM Thread Starter
Hangaround
 
Join Date: Sep 2014
Location: Michigan
Posts: 87
Finally got it. Thanks for the input!
mray81 is offline  
post #7 of 10 (permalink) Old 10-06-2014, 08:09 PM
Life Member
 
Triplej's Avatar
 
Join Date: Oct 2011
Location: Nevada, TX
Posts: 5,434
Quote:
Originally Posted by mray81 View Post
Finally got it. Thanks for the input!
How many beers did it take A couple more and a few deep breaths usually does the trick for me


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Triplej is offline  
post #8 of 10 (permalink) Old 10-06-2014, 08:11 PM
Member
 
RoadGlideGary's Avatar
 
Join Date: Feb 2011
Location: Golden Colorado
Posts: 462
Quote:
Originally Posted by Big_gary View Post
Yea, just keep messing with it. You will get it. It always takes me a few times too. Its all about alignment.
++ on the advice. You can't mess it up. I practiced with mine after watching the video and never had a problem. Then I took the ignition switch and upper retainer off when I did my suspension upgrade. Exact same issue you have. Try and walk away. Try inserting with knob in off position (not locked position) pushing tab up ( key in) but not turning key to full left until you have knob full left and depressed, then turn key full left. There are only a few options. It is not F'd up - just a sequence / initial insert issue. I'd try on mine again to confirm but I'd F it up!

08' FLTR - Customized!!! (Check my Albums)
05' SuperGlideCustom - sold
RoadGlideGary is offline  
post #9 of 10 (permalink) Old 10-06-2014, 08:29 PM
Member
 
Join Date: Jul 2013
Location: Heart of Texas
Posts: 532
What really sucks is when you get it right the first two times you tear it out thinking you are the Jedi Master better than everyone else and then the third time you jack it up ..... after a few beers still jacked up ..... 24 hours later get it right. It's like a right of passage, you WILL jack it up
jethro_3 is offline  
post #10 of 10 (permalink) Old 10-07-2014, 05:47 AM Thread Starter
Hangaround
 
Join Date: Sep 2014
Location: Michigan
Posts: 87
Yep, tried it a few times before this with no issue. Even did it on a friends bike while mine was jacked up just to make sure I wasnt missing something. Totally frustrating but happy its fixed.
mray81 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Removing your ignition switch joke Do-IT-Yourself 21 01-05-2019 03:18 PM
Help removing ignition switch. Switch seems stuck? Driftah Controls & Handlebars 5 11-04-2015 08:18 AM
ignition switch Graybone32 *General Road Glide Discussions/Pictures 10 06-27-2011 02:04 PM
2011 RGU Handlebar swap / ignition switch question craigp95 Controls & Handlebars 6 06-22-2011 06:03 PM
Chrome Ignition Switch Cover for Road/Glide cestaro Aftermarket Accessories 4 06-06-2011 06:17 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome