Speedometer is really sporadic - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 02-03-2015, 12:17 PM Thread Starter
G
Hangaround
 
G's Avatar
 
Join Date: Oct 2010
Location: Palm Desert, CA
Posts: 192
Speedometer is really sporadic

I can be moving down the road and the speedometer just drops out...down to zero. Then will start working again. No pattern to this, I've tried to duplicate it with no success. Speeds, gears, accelerating, decelerating...no pattern at all...just randomly drops and returns to working when it wants to.

I have seen than when it drops out and is on zero...occasionally the 6th gear light will flash and the turn signals won't cancel. Don't know if these are related, but it's very consistent when the speedo isn't working.

Don't know if it's mechanical or electrical.

Guess I'm going to have to take it to the shop, but before I do, wanted to get the best wisdom here so I can get the best results there. I'd appreciate your help.

Thanks!

DETERMINED to spend more time riding this bike and less time wrenching and customizing!

2011 FLTRX with 103. Rinehart 4" slip-ons (
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
). Stock head pipes. Chrome SE Ventilator Air Clean (
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
).
G is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 02-03-2015, 12:28 PM
Member
 
hometoast's Avatar
 
Join Date: Aug 2013
Location: 18707
Posts: 714
Garage
Sounds like it MIGHT be a bad speed sensor. https://www.roadglide.org/showthread.php?t=167793

Pull the codes (https://www.roadglide.org/showthread.php?t=4439) and see what that tell you too.

2013 Candy Orange FLTRX

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
hometoast is offline  
post #3 of 3 (permalink) Old 02-03-2015, 02:02 PM Thread Starter
G
Hangaround
 
G's Avatar
 
Join Date: Oct 2010
Location: Palm Desert, CA
Posts: 192
Thanks a ton!
G is offline  
Reply

Tags
electrical , failure , speedo

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Trans oil really, really hot! August Fluids and Lubricants 6 09-12-2014 05:44 PM
I really really like my RGU . . . . RonC26 *General Road Glide Discussions/Pictures 18 09-02-2014 06:55 PM
Sporadic knock at idle new tw-777 cam ChivoChavez321 Suspensions 6 10-26-2013 11:24 AM
Wtb-silver faced speedometer JPROADGLIDE Classifieds Archive (3 months old+) 3 02-15-2011 12:59 PM
I'm just being really really picky... BDMastiff *General Road Glide Discussions/Pictures 13 12-31-2010 11:11 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome