2015 charging issue - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-12-2015, 01:00 AM Thread Starter
Hangaround
 
vtglide's Avatar
 
Join Date: Apr 2012
Posts: 68
2015 charging issue

I have a 2015 flrtx and tonight when i was pulling my bike into the garage i noticed that my battery light was on my bike only showed 12v on the gauge. I shut the bike off and then just turned the ignition to the on position and it showed 12 volts. I then started the bike and it still only showed 12v. I think that its not charging the battery when its running. I didnt really have much time to mess around with it but was hoping someone could point me in the right direction to checking out the charging system and where i can find the voltage regulator and other things to check to trouble shoot the issue. The owners manual says to check for a bad grounding strap connection. Where can i find that? The bike is completely stock and only has 5xx miles on it. I am planning on riding to laconia on Saturday and i hope to find a loose wire or something easy. I also plugged it into a battery tender to charge the battery overnight. I hope i can find the issue tomorrow or it looks like no laconia for me this year... thanks guys!

2015 FLTRX vivid black...
vtglide is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-12-2015, 02:16 AM
Member
 
Wood's Avatar
 
Join Date: Mar 2010
Location: Arizona
Posts: 421
Take it to the dealer for warranty work; probably the voltage regulator. The VR is a common defect, quality problem with Harley's.

2010 FLTRX Vivid Black, WindVest, Catless, 3-S&S Std Lifters, 1-Oversized Fueling Lifter, Adjustable Pushrods, Power Vision, Oil Temp, Hidden Antenna. 1975 FXE Shovelhead, CV, Electronic Ignition, Primary Belt Drive, owned since 1976.
Wood is offline  
post #3 of 5 (permalink) Old 06-12-2015, 10:25 AM
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,528
+1 on the Voltage Regulator, it could also be the stator too, but taking it in to the dealer as mentioned would be the right thing to do since the bike is under warranty.
I wouldn't ride the bike to the dealer if the dealer is too far away because once the battery goes dead the bike will shut down and you will be stuck on the side of the road waiting on a tow truck.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
 
post #4 of 5 (permalink) Old 06-12-2015, 05:28 PM Thread Starter
Hangaround
 
vtglide's Avatar
 
Join Date: Apr 2012
Posts: 68
i called my dealer and told them that i was planning to leave tomorrow to go to laconia and he told me that if i could get the bike to them that he would make sure that i would make my trip. So i loaded it into the back of my truck and headed to the dealer. It ended up being a loose connection on the volatage regulator. I was happy that they could get me right in and take care of me. So it looks like im NH bound tomorrow!

2015 FLTRX vivid black...
vtglide is offline  
post #5 of 5 (permalink) Old 07-02-2015, 11:44 AM
Member
 
bikepsych's Avatar
 
Join Date: Aug 2010
Location: Gold Coast of California
Posts: 326
Garage
Glad to hear the problem was resolved. I'm still trying to chase my charging problem. I'm stuck with trying to figure out where the ground wire from the battery is anchored to the engine or frame. Anyone have a picture of can give me the location? I'm figuring to clean all connections first and see if that resolves the 11 volt at 3000rpm problem...probably not but what the heck, that process is fairly free and easy.

Thanks in advance.

bikepsych, 2017 RoadGlide Ultra
Supertrapp Fatshots, SE A/C, 107 2 114 kit
bikepsych is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2015 charging issue vtglide Tech Area 2 06-12-2015 01:07 AM
Ground studs/Intermittant charging issue thedrill Engine Related 3 07-17-2014 07:54 PM
iPhone 4S - Charging/Not Charging dinggus Audio 8 11-01-2013 09:25 AM
charging system issue crosen41 Troubleshooting for Road Glides 6 05-07-2013 02:03 PM
Charging Issue EasternSP Troubleshooting for Road Glides 2 08-13-2010 11:06 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome