2000 RG cutting off while riding then cuts back on - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-04-2015, 08:06 PM Thread Starter
Newbie
 
Join Date: Aug 2015
Posts: 1
2000 RG cutting off while riding then cuts back on

Can anybody give me an idea of why my 2000 RG cuts off while I'm riding them cuts back on, it doesn't always do it the problem started Saturday,I parked it then got back on on it later on in the day then it didn't do it anymore
Lamar619 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-05-2015, 11:59 AM
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,528
When it cuts off is it like the ignition shuts off? Does the gauges go dead when it cuts off?? If it does then you have the 40 amp breaker going bad and it needs to be replaced.
Your 2000 model has a main breaker that will overheat and break when going bad and when it cools it will reset. HD put a 40 amp fuse in the newer models because of the breaker problems.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Something happened to my engine while riding back today edimean22 *General Road Glide Discussions/Pictures 28 05-20-2018 12:27 AM
Engine chirping/rattle then BANG - then nothing Methos1979 Troubleshooting for Road Glides 16 07-02-2016 10:11 AM
Speakers cutting in/out while riding SemperGlide13 Audio 5 03-28-2015 09:33 PM
Bezel Fell off while riding ? Jay2Beers Lighting 18 07-12-2013 12:07 AM
Sound system cuts back volume over half way Batbiker Audio 2 04-22-2013 02:53 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome