new member new glide new problem - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 09-24-2010, 10:43 AM
CROSS
Guest
 
Posts: n/a
new member new glide new problem

Hello ,, everyone ,, just registered in here ,, been ridin last 22 yrs ,, i have a 74 shovel,, 97 dyna ,, and just got a 1999 road glide do those fairings ever spoil ya ,, im in Newfoundland ,, question for ya ,, lst night well out with the warden i had on the acces lights and they blew the 15 amp fuse in under the seat ,, is this a common thing that ppl encounter or what ,, it seems the more options the more problems ,, anything in particuar to check for Thanks Dave
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 09-24-2010, 10:47 AM
Admin
 
BillyBob's Avatar
 
Join Date: Sep 2009
Location: Mississippi
Posts: 4,274
welcome mate, don't think it's common but there are some people here who can answer it better than I. Hopefully they'll chime in.

Welcome to the darkside

2010 FLTRX Red / The First Roadglide / "There's no Ride like a Glide"


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
BillyBob is offline  
post #3 of 7 (permalink) Old 09-24-2010, 11:27 AM
CROSS
Guest
 
Posts: n/a
Question

Thanks for the welcome ,, i just went and picked up another fuse to see if it was a bad fuse .... Not llikely it blew right away ,,,, all other lights work stereo everything what the hell did i get myself into before i start go into it any obvious places you check Thanks
 
post #4 of 7 (permalink) Old 09-24-2010, 11:31 AM
Life Member
 
BigDaveOnBass's Avatar
 
Join Date: Apr 2010
Location: Evans, GA
Posts: 1,634
Send a message via Yahoo to BigDaveOnBass
Accessory lights? Extra lights above and beyond the factory lights? If so, sounds like a grounding issue. Or the fuse can't handle the extra load from the lights. I'd say try a 20 amp fuse, but that may lead to melted wires if it is a ground issue.

'04 FLTRI, originally Smokey Gold, now Vivid Black, 95", S/E forged high comp 9.6:1 pistons, Andrews 37G cams, Big Boyz heads, S/E adjustable pushrods, S/E Race Tuner, S/E Stage 1 kit, V&H Dresser Duals, S/E slip ons, H-D premium oil cooler, chromed wagon wheels, Brembo/H-D front brakes, added rear engine guards, Paul Yaffe 10" OEM Monkey Bars, detachable tour pak


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
BigDaveOnBass is offline  
post #5 of 7 (permalink) Old 09-24-2010, 11:43 AM
CROSS
Guest
 
Posts: n/a
yEah there fog lights i believe i dint realize they didnt come witout them ill give ya a pic later Thanks man il check for ground and burrs
post #6 of 7 (permalink) Old 09-24-2010, 02:12 PM
Life Member
 
Shrug's Avatar
 
Join Date: Mar 2010
Location: Wills Point, Texas
Posts: 2,218
Garage
+1 Ground issue. If they're add-on lights, can you just re-run the circuit using existing wiring? You'll likely uncover the problem if you do.

Welcome to the shark frenzy!



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Shrug - Scott Wilson
2010 FLTRX "Hester 2.0" -
Blue Knights Texas Chapter XLVI
Shrug is offline  
post #7 of 7 (permalink) Old 09-24-2010, 08:32 PM
CROSS
Guest
 
Posts: n/a
Thanks headin out to rewire right know
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 FLHT Electra Glide Standard electrical problem - FAST Help needed FLTRXpilot Troubleshooting for Road Glides 4 03-07-2014 03:20 PM
08 Electra Glide - Cruise Control Problem gaillarry Controls & Handlebars 7 03-29-2013 04:34 PM
08 glide Power Commander mounting problem skidmark1964 Troubleshooting for Road Glides 0 09-14-2012 12:40 PM
04 road glide cruise problem fatboyjdb Troubleshooting for Road Glides 1 06-22-2011 08:42 PM
Another problem with the Glide BDMastiff *General Road Glide Discussions/Pictures 5 09-30-2010 04:09 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome