left turn signal - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 09-27-2010, 04:18 AM Thread Starter
Newbie
 
Join Date: Jan 2010
Location: dunnellon,fl
Posts: 25
left turn signal

ok folks, gotta gremlin! when i try to use left turn signal, the security light comes on? bike runs great. security light goes out at start up and stays out till i try to use left turn signal. i changed bulbs, no help. ???????
rdbateman is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 09-27-2010, 10:21 AM
Life Member
 
CHAINSAW's Avatar
 
Join Date: Sep 2009
Location: SW Kansas - Hugoton
Posts: 8,225
Have you checked/changed both your front and back bulbs? Are you running standard bulbs, or LEDs?

Mine did this when I installed LEDs in the front, along with a fast blink after a couple of seconds. Once I put load equalizers on, it worked fine. Its wired in, that if you have a bulb burned out the security light will come on when you hit that turn signal.






For a wounded man shall say to his assailant,
'If I live, I will kill you. If I die, You are forgiven.'
Such is the rule of honor.


CHAINSAW is offline  
post #3 of 15 (permalink) Old 09-28-2010, 10:40 AM Thread Starter
Newbie
 
Join Date: Jan 2010
Location: dunnellon,fl
Posts: 25
Thanks for your help CHAINSAW
I replaced the front light with sylvania 1157 and rear with sylvania 1156 from local auto parts store. I take it these are standard replacement bulbs? Or, do i need to get HD replacements?
rdbateman is offline  
 
post #4 of 15 (permalink) Old 09-28-2010, 11:05 AM
Life Member
 
CHAINSAW's Avatar
 
Join Date: Sep 2009
Location: SW Kansas - Hugoton
Posts: 8,225
Quote:
Originally Posted by rdbateman View Post
Thanks for your help CHAINSAW
I replaced the front light with sylvania 1157 and rear with sylvania 1156 from local auto parts store. I take it these are standard replacement bulbs? Or, do i need to get HD replacements?
You don't need to get the HD replacement, the sylvania is fine.

So your turn signals are working now, correct? You turn them on, walk in front and back and make sure they are both working? It could be you just got a bad bulb or there is corrosion on the socket. Its rare, but it happens sometimes that you buy a brand new bulb and its no good out of the package. It could also be, that you installed them wrong,.. again rare and hard to do because of the prongs, but it can be done and they won't work.






For a wounded man shall say to his assailant,
'If I live, I will kill you. If I die, You are forgiven.'
Such is the rule of honor.


CHAINSAW is offline  
post #5 of 15 (permalink) Old 09-29-2010, 09:25 PM Thread Starter
Newbie
 
Join Date: Jan 2010
Location: dunnellon,fl
Posts: 25
no they are not working. i will check for corrosion and change out with new bulbs. thanks
rdbateman is offline  
post #6 of 15 (permalink) Old 09-29-2010, 11:52 PM
Life Member
 
CHAINSAW's Avatar
 
Join Date: Sep 2009
Location: SW Kansas - Hugoton
Posts: 8,225
Usually you can rattle the bulb next to your ear (if you can hear,.. I can't anymore) and hear if the element is broken. Holding it upside down and looking you will be able to see if something is broken inside.

What is interesting to me,.. neither of them work. What year is your bike?
Also, do the running lights work?






For a wounded man shall say to his assailant,
'If I live, I will kill you. If I die, You are forgiven.'
Such is the rule of honor.


CHAINSAW is offline  
post #7 of 15 (permalink) Old 09-30-2010, 01:21 AM
Newbie
 
Join Date: Aug 2010
Location: Lake City, Fl
Posts: 1
RE: left turn signal

i have the same problem i took my glide to HD and its the signal canceling unit
i dont have the exact name of the part but i can almost guarantee thats what it is
rockydnuts1 is offline  
post #8 of 15 (permalink) Old 09-30-2010, 02:39 AM Thread Starter
Newbie
 
Join Date: Jan 2010
Location: dunnellon,fl
Posts: 25
Quote:
Originally Posted by CHAINSAW View Post
Usually you can rattle the bulb next to your ear (if you can hear,.. I can't anymore) and hear if the element is broken. Holding it upside down and looking you will be able to see if something is broken inside.

What is interesting to me,.. neither of them work. What year is your bike?
Also, do the running lights work?
2006 and yes the running lights work
rdbateman is offline  
post #9 of 15 (permalink) Old 09-30-2010, 03:09 AM Thread Starter
Newbie
 
Join Date: Jan 2010
Location: dunnellon,fl
Posts: 25
Quote:
Originally Posted by CHAINSAW View Post
Usually you can rattle the bulb next to your ear (if you can hear,.. I can't anymore) and hear if the element is broken. Holding it upside down and looking you will be able to see if something is broken inside.

What is interesting to me,.. neither of them work. What year is your bike?
Also, do the running lights work?
2006 and yes the running lights work
rdbateman is offline  
post #10 of 15 (permalink) Old 10-01-2010, 12:19 AM
Life Member
 
CHAINSAW's Avatar
 
Join Date: Sep 2009
Location: SW Kansas - Hugoton
Posts: 8,225
Quote:
Originally Posted by rockydnuts1 View Post
i have the same problem i took my glide to HD and its the signal canceling unit
i dont have the exact name of the part but i can almost guarantee thats what it is
I think this guy is on track on what the problem is. Doesn't sound like the bulbs since you have running lights. I wish I could be more help, but wiring never has been my thing.






For a wounded man shall say to his assailant,
'If I live, I will kill you. If I die, You are forgiven.'
Such is the rule of honor.


CHAINSAW is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Is my left turn signal switch bad??? Dyna-petey Lighting 7 09-22-2017 09:31 PM
Left turn signal will not work justaguy Controls & Handlebars 6 12-31-2013 12:41 AM
Pinched wires, front left signal HellInABucket *General Road Glide Discussions/Pictures 12 06-13-2013 11:21 PM
Going left..... Way left! DarbinCo Troubleshooting for Road Glides 13 09-20-2012 11:16 PM
Left turn signal richrabb *General Road Glide Discussions/Pictures 3 12-14-2011 08:45 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome