Electrical charging gremlins - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 3Likes
  • 2 Post By Smarty
  • 1 Post By ironmark
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 05-09-2016, 06:51 AM Thread Starter
Hangaround
 
mouser58's Avatar
 
Join Date: Oct 2014
Location: Moundsville, West (ByGOD) Virginia
Posts: 134
Electrical charging gremlins

Last summer I hit a BAD pothole... Voltage spiked to 16 volts.. By the time I got to the nearest Harley shop, it had gone back to normal... on several occasions it has reared it's ugly lil head again.. If I let it idle down or shut it off and restart, it clears itself.. Yesterday, out of nowhere, it started to discharge.. Came back to normal twice, but by the time I got home, the gauge was clear down to 8 volts and needless to say the battery was dead... Stater, Voltage regulator or Battery malfunction????

2012 Ultra...Stage 1...Vance & Hines Power Duals,SE Night Sticks, V&H Digital, Stock air box with larger fliter..
mouser58 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 05-09-2016, 07:14 AM
Life Member
 
Smarty's Avatar
 
Join Date: Apr 2015
Location: Royse City, Texas
Posts: 2,930
Really sounds liker the voltage regulator. If it's still doing it, check the voltage in the battery after charging it with a battery charger. Then crank the engine and the voltage should up to about 14.2 or so when you idle it up. If that doesn't happen, it's either the regulator or the stator. Because it had acted right and then messed up, sounds more like the regulator . Usually a stator is usually bad or good. Also, according to how old your battery is, it very well could be a cell shorting out. You might take it out after a full charge and take it to an AutoZone or one of the other supple houses and get it tested.
mouser58 and Jacksprat56 like this.

2016 RGS Black Quartz
Smarty is offline  
post #3 of 6 (permalink) Old 05-09-2016, 09:47 AM
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,528
VR usually goes bad and that it, it really doesn't go bad then come back multiple times, but there may be exceptions, the 2012 had a VR recall so check and see if the bike had the VR replaced under the recall. A stator will charge @ 14 + volts when the bike is first started and then as things warm up the voltage will drop.
A shorted stator can cause the problem you describe, you could also have a bad ground or battery connection so check them first.
mouser58 likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.

Last edited by ironmark; 05-09-2016 at 09:52 AM.
ironmark is offline  
 
post #4 of 6 (permalink) Old 05-10-2016, 09:05 AM Thread Starter
Hangaround
 
mouser58's Avatar
 
Join Date: Oct 2014
Location: Moundsville, West (ByGOD) Virginia
Posts: 134
I kept bike on Tender all night... Turned it on, 12 volts.... Started, 14 volts and charging... Took it out for a ride and working perfectly WTH?????

2012 Ultra...Stage 1...Vance & Hines Power Duals,SE Night Sticks, V&H Digital, Stock air box with larger fliter..
mouser58 is offline  
post #5 of 6 (permalink) Old 05-15-2016, 09:16 AM
Newbie
 
Join Date: Sep 2012
Location: Florida
Posts: 23
mouser58,don't push your luck if it happens again.running off your battery can damage it and add to repair cost.my charging system went friday .made it home and had it towed to indie saturday.battery was good after night on tender but i didn't want to risk loosing power in tampa traffic.bad vr left me on side of highway on new 97 electra glide.recall program for your bike ended 2 yrs ago so that won't help.i had recall done in 2012 so i guess replacement parts only slight improvement.repair on 97 was still good when traded in 2010

2012 RGU Cobra Fi2000 POWER PRO ,Cobra POWER FLO ac,RUSH 2:1,Madstad,J&M performance series speakers
guyflh is offline  
post #6 of 6 (permalink) Old 06-02-2016, 10:28 AM Thread Starter
Hangaround
 
mouser58's Avatar
 
Join Date: Oct 2014
Location: Moundsville, West (ByGOD) Virginia
Posts: 134
Turned out to be the Voltage Regulator... Replaced, 300 miles and no issues...

2012 Ultra...Stage 1...Vance & Hines Power Duals,SE Night Sticks, V&H Digital, Stock air box with larger fliter..
mouser58 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical Charging Question groupw Troubleshooting for Road Glides 6 04-26-2014 12:11 PM
iPhone 4S - Charging/Not Charging dinggus Audio 8 11-01-2013 08:25 AM
Electrical Not Charging Again jimmyray11349 *General Road Glide Discussions/Pictures 2 05-19-2013 09:50 PM
Possible Electrical Charging issues??? paco ritter Troubleshooting for Road Glides 5 10-05-2012 09:26 PM
Electrical System Not Charging jimmyray11349 Troubleshooting for Road Glides 3 03-23-2012 07:31 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome