Instruments dead in 2016 FLTRXS - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-14-2016, 11:25 AM Thread Starter
Newbie
 
scopet563's Avatar
 
Join Date: Jan 2014
Posts: 6
Instruments dead in 2016 FLTRXS

Anyone turned on the bike and found everything dead? Fuses are good. Dealer says dead speedometer and it has master control. Parts 7-10 days. Only bad thing is not knowing fuel level.
scopet563 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-15-2016, 06:59 AM
Newbie
 
Join Date: May 2016
Posts: 39
Same issue on 2015 RG this week. Dealer says water in speedometer which controls all gages You can actually see the fog in them. They also said it's a common problem and HD is aware, but no fix. What gets me is HD would not overnight the parts!
dbeny is offline  
post #3 of 5 (permalink) Old 05-15-2016, 07:32 AM
Member
 
Gary R's Avatar
 
Join Date: Dec 2011
Location: Pensacola, Florida
Posts: 700
I had a bent pin on the speedo connector cause the same problem. Luckily was able to straighten it without breaking it.

Water in speedo? Interesting. I notice some condensation in mine a few weeks ago.
Gary R is offline  
 
post #4 of 5 (permalink) Old 05-15-2016, 07:47 AM
Life Member
 
smitty901's Avatar
 
Join Date: Feb 2011
Location: Southeast Wisconsin
Posts: 2,588
Water got mine on my 2016 RGU 40 MPH plus winds and down pour for two days. Dealer warrantied it. Whole unit is just swapped out Speed and tach. It also caused me to lose all gauges.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
smitty901 is offline  
post #5 of 5 (permalink) Old 07-15-2016, 08:51 AM
Newbie
 
Roll on's Avatar
 
Join Date: Jul 2016
Posts: 5
Same issue all gauges and idiot lights dead took it to dealer yesterday. no word yet 2016 RGU 1100 miles
Roll on is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2016 FLTRXS 1000Mi Review motodrummer *General Road Glide Discussions/Pictures 12 08-31-2016 03:15 AM
2016 FLTRXS first impressions thealien *General Road Glide Discussions/Pictures 5 03-11-2016 11:06 AM
2016 FLTRXS with ArcAudio MPAC6 Khaotic Audio 4 03-01-2016 06:14 AM
Glare from instruments August *General Road Glide Discussions/Pictures 4 08-28-2014 03:45 PM
Condensation in instruments? andytheuke Troubleshooting for Road Glides 6 09-26-2011 10:49 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome