Trouble Code 0572 - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 06-05-2016, 07:55 AM Thread Starter
Life Member
 
Q-Hog's Avatar
 
Join Date: Jan 2011
Location: Georgia
Posts: 7,280
Trouble Code 0572

Need some help figuring out a problem on my 12 RG. My accessories fuse keep popping.. when it pops, the turn signals, brake lights don't work and cruise control light won't switch on when pressed. Also I have a trouble code of 0572 which is the rear brake switch. Thx.


Sent from Motorcycle.com Free App


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
To the GREAT white North! and Join us for SharkWeekVI Eh!
August 2-3-4 2016 - For registration information click
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Q-Hog; 06-05-2016 at 10:24 AM.
Q-Hog is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 06-05-2016, 09:03 AM
Member
 
Join Date: Jul 2015
Location: Vacaville, CA
Posts: 317
My guess is the cruise control does not work due to the code. My experience is that the cruise is disabled when there is something wrong.
The lights, I have no idea. sounds like it is time to take it in and have it looked at. Have you cleared the code, to see if it comes back again?
Diverrick is offline  
post #3 of 12 (permalink) Old 06-05-2016, 09:16 AM
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,528
Did you unplug the rear brake light switch and see if the fuse holds? It may be a good place to start, if the the fuse pops with the brake switch unplugged then use a multimeter to check if there is a short in the plug or wires.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
 
post #4 of 12 (permalink) Old 06-05-2016, 10:30 AM Thread Starter
Life Member
 
Q-Hog's Avatar
 
Join Date: Jan 2011
Location: Georgia
Posts: 7,280
I haven't troubleshoot it too far. I just checked the wires along the frame to see if any were pinched. I found none. I'll take your advise and try unplugging the brake switch. But I confused when the blown accessories fuse would cause brake light and turn signal inoperable. Thx.


Sent from Motorcycle.com Free App


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
To the GREAT white North! and Join us for SharkWeekVI Eh!
August 2-3-4 2016 - For registration information click
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Q-Hog is offline  
post #5 of 12 (permalink) Old 06-05-2016, 11:46 AM
Member
 
Smokey's Avatar
 
Join Date: Feb 2015
Location: So Cal.
Posts: 310
Garage
Sounds like the brake switch itself may be shorting out. Besides the brake lights and turn signals not working, the cruise control will also be disabled if this switch is bad. You need to confirm it's the back brake switch and not the front although the code indicates the back. Put a new fuse in and pull the front brake. If the fuse doesn't blow then try the back brake. When you find out which circuit (front or back) is blowing the fuse test that switch. If the switch is good then start tracking the wires in that circuit (front or back) starting at the switch.

Last edited by Smokey; 06-05-2016 at 11:50 AM.
Smokey is offline  
post #6 of 12 (permalink) Old 06-05-2016, 12:56 PM Thread Starter
Life Member
 
Q-Hog's Avatar
 
Join Date: Jan 2011
Location: Georgia
Posts: 7,280
Good info. The fuse pop as soon as I insert it.


Sent from Motorcycle.com Free App


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
To the GREAT white North! and Join us for SharkWeekVI Eh!
August 2-3-4 2016 - For registration information click
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Q-Hog is offline  
post #7 of 12 (permalink) Old 06-05-2016, 02:06 PM Thread Starter
Life Member
 
Q-Hog's Avatar
 
Join Date: Jan 2011
Location: Georgia
Posts: 7,280
Smarty, also I while the fuse is blown I have no rear running light and front turn signals as well. But the head light and high beams work.


Sent from Motorcycle.com Free App


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
To the GREAT white North! and Join us for SharkWeekVI Eh!
August 2-3-4 2016 - For registration information click
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Q-Hog is offline  
post #8 of 12 (permalink) Old 06-06-2016, 08:30 AM
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,528
If the fuse blows as soon as you put it in then there is a direct short somewhere.
Did the fuse blow when you turned on the ignition or did it blow when the ignition is off.
If the fuse blew with the ignition off then the short may be in a feature that stays on all the time such as the security system.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
post #9 of 12 (permalink) Old 06-06-2016, 08:41 AM Thread Starter
Life Member
 
Q-Hog's Avatar
 
Join Date: Jan 2011
Location: Georgia
Posts: 7,280
It only blows when the ignition is turned on. Very strange. I have not don't anything to the bike in several month and now for this to happen. I don't really know where to start to check for a bad wire.


Sent from Motorcycle.com Free App


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
To the GREAT white North! and Join us for SharkWeekVI Eh!
August 2-3-4 2016 - For registration information click
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Q-Hog is offline  
post #10 of 12 (permalink) Old 06-06-2016, 08:49 AM Thread Starter
Life Member
 
Q-Hog's Avatar
 
Join Date: Jan 2011
Location: Georgia
Posts: 7,280
It only blows when the ignition is turned on. Very strange. I have not done anything to the bike in several months and now for this to happen. I don't really know where to start to check for a bad wire.


Sent from Motorcycle.com Free App


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
To the GREAT white North! and Join us for SharkWeekVI Eh!
August 2-3-4 2016 - For registration information click
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Q-Hog is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error code question or at least I think it's an error code wvdave Troubleshooting for Road Glides 1 07-15-2015 10:21 AM
Need help. On the road trouble code P0118 DC-3Mek ECM/Fuel Management systems 21 08-20-2013 05:53 PM
Hydraulic Clutch throwing trouble code 69 A-body Controls & Handlebars 3 08-29-2011 08:10 PM
New bars on...getting a trouble code BigDum Controls & Handlebars 6 08-19-2011 12:03 AM
Signature Pic Trouble Rottiman *General Road Glide Discussions/Pictures 5 06-28-2010 11:50 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome