Clutch Issue? - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 07-06-2016, 06:32 PM Thread Starter
Hangaround
 
JDisMe's Avatar
 
Join Date: Mar 2016
Location: Bloomingdale, IL
Posts: 183
Garage
Clutch Issue?

So I searched a bit at work today about what I have going on and there's some similar posts about it but they seem to have more symptoms than I do, so I'm not really sure about it.

I bought my, new to me, '12 RGC about 3 months ago with 1433 miles on it. The dealer I bought it from had no record of the 1k service being done, so I took it in to have it done a couple of weeks ago, just so I KNEW it was done.

Mobil 1 Syn. in the engine.
HD F+ in the primary
Redline Shockproof in the tranny.

I will be going Redline for all 3 from here on out, I just had some left overs I wanted to use.

Anyways, I got the bike back, she ran tip top: better, smoother shifting, seemed to run cooler, etc.

So this past weekend me and a couple buddies went for a cruise, put about 120 miles on. Everything ran fine. Picked up my girlfriend and we did a little ride and grabbed some dinner.

When I was riding back to park the bike, something just felt off on the left side by my foot. I know this may sound cheesy but the only way I can describe it is, something just felt loose inside somewhere. Bike seemed to be shifting fine. With the 2 of us on the bike, I'm sure it had to work a bit more to get going but nothing major. At first, I thought maybe it was just my bell smacking the bottom of the bike.

When I got back to the house, I parked it, and walked up to open the garage and when I got back on it, I threw it into first and scooted up the driveway but when I let the clutch lever out, it made a loud "smack" that sounded like I was shifting. One of my buddies was there and heard it too.

I was doing between 5 & 10 mph and after I got it in the garage, just sitting on the bike, engaging and disengaging the clutch, it made no "smack" sounds.

Due to work and life, I haven't had a chance to ride it again, but this ha been bothering me all day.

I see all the posts about possible compensators taking a dump or bearings getting blown or worn out and I'm starting to wonder if I may be doing some serious damage. Some of the posts have riders that have been dealing with that clunking for years.

Any thoughts? I'm going to try to get it out tomorrow but we have some rains coming in so who knows.

Any thoughts would be appreciated. Did I fuck up my ride? Bike's got about 2800 miles on it now.

--2019 RGS--
--2012 Road Glide Custom--Gone But Not Forotten

Last edited by JDisMe; 07-06-2016 at 06:40 PM.
JDisMe is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 07-06-2016, 06:56 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,064
Garage
Quote:
Originally Posted by JDisMe View Post
So I searched a bit at work today about what I have going on and there's some similar posts about it but they seem to have more symptoms than I do, so I'm not really sure about it.

I bought my, new to me, '12 RGC about 3 months ago with 1433 miles on it. The dealer I bought it from had no record of the 1k service being done, so I took it in to have it done a couple of weeks ago, just so I KNEW it was done.

Mobil 1 Syn. in the engine.
HD F+ in the primary
Redline Shockproof in the tranny.

I will be going Redline for all 3 from here on out, I just had some left overs I wanted to use.

Anyways, I got the bike back, she ran tip top: better, smoother shifting, seemed to run cooler, etc.

So this past weekend me and a couple buddies went for a cruise, put about 120 miles on. Everything ran fine. Picked up my girlfriend and we did a little ride and grabbed some dinner.

When I was riding back to park the bike, something just felt off on the left side by my foot. I know this may sound cheesy but the only way I can describe it is, something just felt loose inside somewhere. Bike seemed to be shifting fine. With the 2 of us on the bike, I'm sure it had to work a bit more to get going but nothing major. At first, I thought maybe it was just my bell smacking the bottom of the bike.

When I got back to the house, I parked it, and walked up to open the garage and when I got back on it, I threw it into first and scooted up the driveway but when I let the clutch lever out, it made a loud "smack" that sounded like I was shifting. One of my buddies was there and heard it too.

I was doing between 5 & 10 mph and after I got it in the garage, just sitting on the bike, engaging and disengaging the clutch, it made no "smack" sounds.

Due to work and life, I haven't had a chance to ride it again, but this ha been bothering me all day.

I see all the posts about possible compensators taking a dump or bearings getting blown or worn out and I'm starting to wonder if I may be doing some serious damage. Some of the posts have riders that have been dealing with that clunking for years.

Any thoughts? I'm going to try to get it out tomorrow but we have some rains coming in so who knows.

Any thoughts would be appreciated. Did I fuck up my ride? Bike's got about 2800 miles on it now.
Can you wrench ? I'd pull the primary just to have a look. Any aftermarket parts on the sled ?
BTW Those combinations of oil your running are a good choice. I wouldn't change anything.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
post #3 of 8 (permalink) Old 07-06-2016, 07:39 PM Thread Starter
Hangaround
 
JDisMe's Avatar
 
Join Date: Mar 2016
Location: Bloomingdale, IL
Posts: 183
Garage
I do minor things to my bike, never any drivetrain work. I could pull the cover and scope around in there, but I don't know if I know what I'd be looking for/at. My bike's still under warranty so not sure how much I would want to poke around if it's something MoCo would cover.

I'm gonna call my guy up at the dealer tomorrow since he called me yesterday and asked how the bike was running after they did the service work. I missed his call anyways.

As for my oils, I wanted to try out the primary oil from Redline. My dealer carries the full line of Redline stuff so it's not hard to get.

--2019 RGS--
--2012 Road Glide Custom--Gone But Not Forotten

Last edited by JDisMe; 07-06-2016 at 07:45 PM.
JDisMe is offline  
 
post #4 of 8 (permalink) Old 07-06-2016, 07:54 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,064
Garage
Quote:
Originally Posted by JDisMe View Post
I do minor things to my bike, never any drivetrain work. I could pull the cover and scope around in there, but I don't know if I know what I'd be looking for/at. My bike's still under warranty so not sure how much I would want to poke around if it's something MoCo would cover.

I'm gonna call my guy up at the dealer tomorrow since he called me yesterday and asked how the bike was running after they did the service work. I missed his call anyways.

As for my oils, I wanted to try out the primary oil from Redline. My dealer carries the full line of Redline stuff so it's not hard to get.
Some folks reported slippage with Redline primary oil in the primary, some don't. Just saying.
I agree, if it's still under warranty and they just worked on it, let them check it out. If it's still making noise riding out of the driveway , have them come tow it.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
post #5 of 8 (permalink) Old 07-06-2016, 07:58 PM Thread Starter
Hangaround
 
JDisMe's Avatar
 
Join Date: Mar 2016
Location: Bloomingdale, IL
Posts: 183
Garage
Quote:
Originally Posted by Big_gary View Post
I agree, if it's still under warranty and they just worked on it, let them check it out. If it's still making noise riding out of the driveway , have them come tow it.
That's what I'll probably do. I think I was just freaking out that I may have seriously fucked something up.

--2019 RGS--
--2012 Road Glide Custom--Gone But Not Forotten
JDisMe is offline  
post #6 of 8 (permalink) Old 07-07-2016, 08:58 AM
Life Member
 
Woodman's Avatar
 
Join Date: Apr 2015
Location: Washington
Posts: 2,395
Garage
Yep you got the warranty let the dealer mess with it. You didn't do anything but ride it.
Woodman is offline  
post #7 of 8 (permalink) Old 07-13-2016, 07:56 PM Thread Starter
Hangaround
 
JDisMe's Avatar
 
Join Date: Mar 2016
Location: Bloomingdale, IL
Posts: 183
Garage
Update: I called the dealership and told them what was happening and the guy asked me how many miles I had on the bike. He said that it sounded like the compensator was still getting settled in since I had under 5k miles on it. I came right out and asked if I was damaging anything and he said he didn't think so, but of course, if I was concerned about anything with the bike, to stop by and they would have someone take it for a ride and see if they found anything out of line. I told him that I heard it when I was going under 10mph and he said that that is when I would hear it and not to worry too much about it.

I ended up letting a friends dad take it for a ride and asked his opinion. He's been riding almost 40 years and if he tells me somethings wrong, I believe it. He said it seemed fine, just that my brakes were squeaky a bit.

So I ended up riding it that day for about 100 miles, with my girl on the back and I only heard that "smack" sound once.

So we shall see. So far so good. Maybe I'm just paranoid.

--2019 RGS--
--2012 Road Glide Custom--Gone But Not Forotten
JDisMe is offline  
post #8 of 8 (permalink) Old 07-13-2016, 08:24 PM
Grey beard
 
lil chief's Avatar
 
Join Date: Jul 2015
Location: Nebraska
Posts: 972
Garage
Could it have possible been a caliper hanging up? Then as soon as you moved forward it broke loose?

Lil Chief

Famous Last Words: "Watch Me!"

2015 Denim Black RG, FM ss ceramic coated 2-1-2 pipe, White Bros Original E Series Mufflers, FM ac, PV Tuner
lil chief is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
I talk to Redline about clutch issue. Hillglide *General Road Glide Discussions/Pictures 13 04-01-2013 05:26 PM
Apparently, this isn't my week. Possible clutch issue RGCBandit Troubleshooting for Road Glides 3 10-15-2012 08:53 AM
Clutch issue - adjust itself.. TheDon81 Troubleshooting for Road Glides 3 07-19-2012 09:52 AM
Clutch issue BaggerBrian Troubleshooting for Road Glides 7 05-31-2012 09:46 AM
Clutch issue... ZachB Troubleshooting for Road Glides 21 04-19-2012 07:33 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome