'11 RGU one turn signal stuck ON - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 08-26-2016, 02:17 PM Thread Starter
Member
 
aviaator's Avatar
 
Join Date: Jul 2011
Location: Midland,VA
Posts: 354
Garage
Exclamation '11 RGU one turn signal stuck ON

2011 Road Glide Ultra. Started bike yesterday AM and right side turn signal stuck on steady. Doesn't flash, just ON all the time, both front and rear. Full CD LED package, including load equalizer, which was my first suspect. I removed the equalizer from the circuit thinking I would just suffer with "hyper flash" until I got another one... Well, that didn't fix the problem. BTW, the CD LEDs are not new - had this package for a couple years now.


In addition, the red key security light is always on as well, but the bike starts and runs just fine. From another site it was suggested that the TSSM module is bad. Anyone know if a new TSSM can be programmed to work with my current security fob or will I need a new one of those too?
Attached Images
File Type: jpg IMG_2712.JPG (119.9 KB, 8 views)
File Type: jpg IMG_2714.JPG (80.8 KB, 11 views)

2011 FLTRU
2006 FXDCI Super Glide

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
aviaator is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 08-26-2016, 02:18 PM Thread Starter
Member
 
aviaator's Avatar
 
Join Date: Jul 2011
Location: Midland,VA
Posts: 354
Garage
PS is Jon at Horny Toad HD still on this forum?

2011 FLTRU
2006 FXDCI Super Glide

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
aviaator is offline  
post #3 of 7 (permalink) Old 08-26-2016, 02:38 PM
PGR
GONE BUT NOT FORGOTTEN
 
PGR's Avatar
 
Join Date: Aug 2010
Location: Western Illinois
Posts: 2,338
Garage
It was me on the other forum. I called my local dealer, about something unrelated, and also asked about your issue.

The new TSSM will need to be married to your bike with the digital technician, and your existing FOBs married to the new TSSM.

As I suggested on the other forum, clean up all the contacts and apply dielectric grease. And I mean all contacts. Also check the wiring harness under the seat that goes towards the rear.


Also check for code thrown by the ECM. If it shows TSSM low signal, it could mean a bad ground. If you have an ohm meter check all your turn signal grounds for continuity.

But unfortunately, the red key light says to me that it's the TSSM that has taken a dump.



I hate electrical gremlins. I chased one for the better part of a year.








......................
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Ron..........................


........2011 Cool Blue Pearl FLTRX........
.............RoboGlide .............


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by PGR; 08-26-2016 at 02:44 PM.
PGR is offline  
 
post #4 of 7 (permalink) Old 08-27-2016, 05:33 AM Thread Starter
Member
 
aviaator's Avatar
 
Join Date: Jul 2011
Location: Midland,VA
Posts: 354
Garage
Wow, thanks for that PGR; that's going above and beyond to help a brother - I appreciate it.

The CEL.is not on. Would TSSM codes still be stored without turning on the CEL?

I'll certainly try cleaning all the contacts really well and using a bit of D/E grease. The fact that all four turn signal lights work tells me that the ground continuity is good but I can check that anyway.

Gonna get started early this AM in case it's gotta go to the dealer to get.the new TSSM and have it married. I can't stand electrical gremlins either
aviaator is offline  
post #5 of 7 (permalink) Old 08-27-2016, 07:34 AM Thread Starter
Member
 
aviaator's Avatar
 
Join Date: Jul 2011
Location: Midland,VA
Posts: 354
Garage
Well, clean & grease didn't help. Checking DTCs was eye opening. Several stored engine codes but they have to do with O2 sensors which is not surprising since I'm running a tuner and have them removed. One was rear cyl no combustion which I'm assuming is due to the ETMS system functioning at times.

HOWEVER, several "B" codes point to the TSSM module:
B1121
B1124
B1126
B1145

Looks like I need a new module. Thanks again for the assistance PGR!

Last edited by aviaator; 08-27-2016 at 09:13 AM.
aviaator is offline  
post #6 of 7 (permalink) Old 08-30-2016, 01:40 PM Thread Starter
Member
 
aviaator's Avatar
 
Join Date: Jul 2011
Location: Midland,VA
Posts: 354
Garage
Update:

Just got back from dealer having new TSSM married to ECU/FOBs and that DID NOT solve the problem. Still have exact same issue: RT turn signal stuck on and red key icon illuminated in speedo.

Will post updates as I do more troubleshooting.

2011 FLTRU
2006 FXDCI Super Glide

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
aviaator is offline  
post #7 of 7 (permalink) Old 08-31-2016, 02:28 PM Thread Starter
Member
 
aviaator's Avatar
 
Join Date: Jul 2011
Location: Midland,VA
Posts: 354
Garage
Solved.

Final verdict: MICE. Nothing wrong with the TSSM.
Attached Images
File Type: jpg IMG_2735.JPG (1,021.9 KB, 6 views)
File Type: jpg IMG_2736.JPG (859.4 KB, 5 views)

2011 FLTRU
2006 FXDCI Super Glide

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
aviaator is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ignition switch Stuck & i mean stuck.... maddmoe Troubleshooting for Road Glides 11 07-08-2016 05:22 AM
One of my front turn signal bolts sheared off HellInABucket *General Road Glide Discussions/Pictures 23 04-22-2015 02:57 PM
RGC Rear Turn Signal on RGU Lu *General Road Glide Discussions/Pictures 2 04-29-2012 10:59 PM
Veterans Day 11/11/11 PittsDriver *General Road Glide Discussions/Pictures 17 11-11-2011 10:47 AM
LED King Tour-Pak Brake/Turn/Tail Lamp Kit on '11 RGU Lu Lighting 13 12-29-2010 11:55 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome