Speedometer not working... - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-07-2017, 01:18 PM Thread Starter
Newbie
 
Join Date: Jul 2013
Location: Princeton, KY
Posts: 5
Garage
Speedometer not working...

Checked for codes, none.

Checked VSS for metal shavings, none whatsoever.

Replaced VSS, no change.

Still lights up but not sure about odometer changing, wasn't watching.

Do I have a grounding problem or speedo shot?



Any help is appreciated.

2006 Black Pearl
Grommet is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 02-08-2017, 09:29 AM
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,528
It' hard to say if the speedometer is shot or not. The best way to check the speedometer would be to put another speedometer in and see if everything works. If you have a friend that has a touring model bike you may be able to swap out speedo's just long enough to see where the problem is.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Neutral light on cruise not working and gear indicator not showing Xman247 Tools and Garages 7 08-11-2018 11:09 AM
Right blinker does not work, red key is on in speedometer [email protected] Lighting 4 06-12-2018 09:46 AM
Gauges, indicators, speedometer, tachometer all quit working Hog Happy Active Military and Veteran's group 5 10-12-2016 05:32 PM
Cruise Not Working Hullhorr Troubleshooting for Road Glides 27 03-22-2011 09:39 PM
Battery died, now speakers not working!!!!!! schnid72 Audio 11 02-12-2011 07:33 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome