Idle speeds up when hot - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 1Likes
  • 1 Post By nytryder
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 04-05-2017, 11:01 AM Thread Starter
Newbie
 
Join Date: Apr 2017
Posts: 4
Idle speeds up when hot

When the motor is hot my idle speeds up when stopped in traffic or waiting at red lights. I can give it gas and it slows to normal but after a few seconds it speed up again. Any ideas of how to fix it?

Gary
Gmarcum13 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 04-05-2017, 11:11 AM
Member
 
Stoic Joker's Avatar
 
Join Date: Feb 2016
Posts: 660
Folks will probably need more details to work with:
Year
Mileage
How modified is it
How high does the idle go...

...More stuff that might be useful.

Scarlet Red 2010 Road Glide Custom named Trixie - She's a flashy little minx..
Basic black 1981 Tour Glide Classic named Alice - She's a sleeper project.
Stoic Joker is offline  
post #3 of 7 (permalink) Old 04-05-2017, 11:34 AM
Grey beard
 
Join Date: Jul 2016
Location: Boise, ID
Posts: 932
Garage
Do you have a Rushmore ('15+) bike? If so the EITMS is probably coming on and shutting down the rear cylinder. Press the INFO button on your right hand controls and it should bring up a screen that shows EITMS. If it says "ACTIVE" when you notice the issue, that is what you are experiencing. Good news is you can turn that function off if you desire.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'15 FLTRXS - V&H Power Duals w/ Screamin' Eagle Street Cannons - Arlen Ness Big Sucker - BT4180.14 w/Arc Moto 602v2 and Polk MM652 - Le Pera Maverick Daddy Long Legs - Advan Lowers - Freedom Shield 15"
macabra11 is offline  
 
post #4 of 7 (permalink) Old 04-05-2017, 11:49 AM Thread Starter
Newbie
 
Join Date: Apr 2017
Posts: 4
Yes it's a '15 R G Special. I'll try your suggestion this afternoon. The "service advisor" at HD said he'd never heard of this issue and set me up for 8am Sat. It's till under warranty but I'd just as soon fix it myself rather than give it up for a whole day.
Thanks,

Gary
Gmarcum13 is offline  
post #5 of 7 (permalink) Old 04-05-2017, 11:52 AM
Prospect
 
WTFranz's Avatar
 
Join Date: Jan 2016
Location: Arizona
Posts: 224
Garage
Quote:
Originally Posted by macabra11 View Post
Do you have a Rushmore ('15+) bike? If so the EITMS is probably coming on and shutting down the rear cylinder. Press the INFO button on your right hand controls and it should bring up a screen that shows EITMS. If it says "ACTIVE" when you notice the issue, that is what you are experiencing. Good news is you can turn that function off if you desire.
And you can actually watch it turn from "Enabled" to "Active" and feel the difference. To change from Enable to Disable Turn your throttle in reverse direction till stop point and hold for 10 seconds...


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mazikeen - 2016 Road Glide Special from Arizona
WTFranz is offline  
post #6 of 7 (permalink) Old 04-20-2017, 04:05 PM
Member
 
nytryder's Avatar
 
Join Date: Mar 2010
Location: Central FL
Posts: 360
With the engine off, turn the ignition on for 5 seconds then off for 5 seconds. Do this 4 0r 5 times. many times this will solve the problem. It's caused by hitting the run off switch to the off position while engine rpm is above normal idle. hope this helps.
ironmark likes this.

2015 FLTRUSE
nytryder is offline  
post #7 of 7 (permalink) Old 04-21-2017, 11:06 AM
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,528
Cycling the ignition switch on then off 5 0r 6 time usually help idle problems. A ignition cycle is turning the switch on then waiting for the engine light to go off the turn the ignition switch off. If that doesn't help then you may have a faulty engine temp sensor.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough idle, seems hot Lucky Engine Related 4 07-28-2015 01:09 PM
hot idle problem firefighterkp Troubleshooting for Road Glides 4 06-11-2014 09:02 AM
rattle noise at idle after hot start. Bush pilot *General Road Glide Discussions/Pictures 19 05-30-2014 06:43 PM
It would not idle hot?? allbrand Tech Area 3 12-12-2012 01:00 PM
won't idle hot allbrand Troubleshooting for Road Glides 10 11-13-2012 05:53 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome