Radio dead ? - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-30-2017, 07:15 PM Thread Starter
Newbie
 
jah1121's Avatar
 
Join Date: Jul 2014
Location: Northwest Indiana
Posts: 18
Garage
Radio dead ?

Need help !!! went for a ride and the radio was completely dead. No clock , no nothing at all

when I started it up. Checked fuse panel, fuse was fine, pulled faring ,all the connections seem fine.

Disconnected battery nothing. Checked connections with test light seems to have power at plug.

Is there an in line fuse somewhere that I cant find or in the radio? Seems odd that the whole thing

is dead. Hate to buy a new head unit if it is another issue. Any and all help or ideas are welcome

2012 Road Glide Ultra Ember Red Sunglo
jah1121 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-30-2017, 07:19 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,067
Garage
Quote:
Originally Posted by jah1121 View Post
Need help !!! went for a ride and the radio was completely dead. No clock , no nothing at all

when I started it up. Checked fuse panel, fuse was fine, pulled faring ,all the connections seem fine.

Disconnected battery nothing. Checked connections with test light seems to have power at plug.

Is there an in line fuse somewhere that I cant find or in the radio? Seems odd that the whole thing

is dead. Hate to buy a new head unit if it is another issue. Any and all help or ideas are welcome
Did you make sure it was turned on ?

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
post #3 of 4 (permalink) Old 07-31-2017, 01:43 PM
Newbie
 
jlayton4's Avatar
 
Join Date: Jul 2017
Location: Charlotte, NC
Posts: 26
Garage
Quote:
Originally Posted by jah1121 View Post
Need help !!! went for a ride and the radio was completely dead. No clock , no nothing at all

when I started it up. Checked fuse panel, fuse was fine, pulled faring ,all the connections seem fine.

Disconnected battery nothing. Checked connections with test light seems to have power at plug.

Is there an in line fuse somewhere that I cant find or in the radio? Seems odd that the whole thing

is dead. Hate to buy a new head unit if it is another issue. Any and all help or ideas are welcome
Im in the same boat man.. I just bought this bike Friday (2015 RGS) and trailered it home. Horrible storms on way home, radio is completely gone. Black as night screen. Checked fuses, connections, I have no Idea. If you find a solution let me know please!
jlayton4 is offline  
 
post #4 of 4 (permalink) Old 05-27-2018, 11:51 PM
Newbie
 
Join Date: Jul 2016
Posts: 6
I had a similar problem that was caused by a low/bad battery. The bike would start, but the longer turning over caused the radio to not fire up. Had the battery tested and it was bad, new battery installed and no problems since.
GFFG13 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio is Dead Drifter -11 Audio 8 05-24-2016 06:20 PM
Troubleshooting dead HK radio? RGCBandit Audio 15 10-22-2012 11:39 PM
Dead radio display Redfish-Joe *General Road Glide Discussions/Pictures 4 05-23-2012 11:30 PM
Radio possibly dead PC PaiN Audio 11 04-07-2012 06:51 PM
dead radio pte359 Troubleshooting for Road Glides 24 09-01-2010 12:35 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome