vehicle information button - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 06-11-2017, 12:35 PM Thread Starter
Hangaround
 
Join Date: May 2017
Posts: 177
vehicle information button

My '17 FLRTX came home from it's 1000 mile service last week and I noticed for the first time yesterday that the vehicle information button doesn't work when the radio is off. I don't ever use the radio and am almost sure that the button was working with the radio off before. Does the button normally only function with the radio on? Thanks, JD
judgedelta is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 06-11-2017, 12:53 PM
Grey beard
 
UT_Larry's Avatar
 
Join Date: Sep 2015
Location: West Valley City, Utah
Posts: 927
Garage
15 RG 4.3 radio info button does work when radio is off. Don't know about the 6.5 radio.
UT_Larry is offline  
post #3 of 6 (permalink) Old 06-11-2017, 01:18 PM Thread Starter
Hangaround
 
Join Date: May 2017
Posts: 177
Thanks. Mine, being as "X", has the el cheapo radio. I'll call the dealer Monday.
judgedelta is offline  
 
post #4 of 6 (permalink) Old 06-11-2017, 03:05 PM
Grey beard
 
UT_Larry's Avatar
 
Join Date: Sep 2015
Location: West Valley City, Utah
Posts: 927
Garage
Quote:
Originally Posted by judgedelta View Post
Thanks. Mine, being as "X", has the el cheapo radio. I'll call the dealer Monday.
No problem. One of the reasons I chose the standard and not the special was the 4.3 radio. Suits my needs perfectly. No need to pay extra for features I'll never use.
UT_Larry is offline  
post #5 of 6 (permalink) Old 06-13-2017, 09:14 PM Thread Starter
Hangaround
 
Join Date: May 2017
Posts: 177
UPDATE: Took my bike in today and after about an hour and a half and a bunch of new parts, the techs discovered that HD had updated the software without telling anyone and now the info button will not work without the radio on. They had a bike on the floor with the old software which would show the info without the radio on, and then after updating, it would not... Makes about as much sense as the Iphone updates, but it is what it is. Anyway, I got a bunch of new parts I didn't need and lost an afternoon I could have used for something else.
judgedelta is offline  
post #6 of 6 (permalink) Old 06-13-2017, 09:35 PM
Grey beard
 
UT_Larry's Avatar
 
Join Date: Sep 2015
Location: West Valley City, Utah
Posts: 927
Garage
Thanks for the info, I'm at least one or two updates behind.
UT_Larry is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Vehicle Speed Sensor Symptons & Replacement mitchdm Tech Area 12 05-24-2019 11:32 PM
Took the York vehicle operations factory tour Steelerdude1 *General Road Glide Discussions/Pictures 6 11-01-2014 08:28 PM
Daytona bound? Emergency Service or need to park your vehicle and trailer CHEAP? GAgirlTrixie Road Trip Discussions/Stories/Pictures 0 02-01-2012 09:06 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome