Missing on hard throttle. - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-25-2017, 12:32 PM Thread Starter
Newbie
 
Join Date: Dec 2013
Location: SEVERN MD
Posts: 3
Missing on hard throttle.

2011 rgcvo ultra
when going into a slow throttle to accelerate the bike responds around 70 mph in 6th gear the bike stutters or miss.
If i accelerate hard the same thing happens in any gear.
DEUCE is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-25-2017, 05:50 PM
Life Member
 
Thermodyne's Avatar
 
Join Date: Jan 2014
Location: South Central PA
Posts: 1,765
Garage
Plug wire, plug, coil. I would check them in that order.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Thermodyne is offline  
post #3 of 3 (permalink) Old 06-25-2017, 06:10 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,064
Garage
Is it throwing any codes ?

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Very loud clank when shifting or getting on throttle or letting off throttle Callahan69 Engine Related 28 11-14-2016 01:09 PM
How hard is too hard? tlottman *General Road Glide Discussions/Pictures 11 08-28-2015 06:42 AM
Strange ping when hard on and off throttle dennisnyhc Troubleshooting for Road Glides 0 05-13-2013 07:55 AM
Am I missing something? STREAK Audio 6 06-20-2011 01:18 PM
Missing Member pte359 *General Road Glide Discussions/Pictures 7 06-02-2010 05:12 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome