M8 Front End/Primary Noise - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-15-2018, 10:53 PM Thread Starter
Newbie
 
Cbordies's Avatar
 
Join Date: May 2017
Posts: 17
M8 Front End/Primary Noise

Hello all,

I have a 17' RGS with the new M8. I recently went out riding with the girlfriend and while on our ride I started to notice an almost metallic "Bell-like" pinging noise coming from the primary side of the bike. It only happens when I get going from a full stop in first gear. I can't pin-point exactly where the noise is coming from as it only happens while riding and after the bike warms up. So, it being time for the 5000 miles service, I decided to remove the primary cover an do some digging. I checked the primary chain tension and it seems to be good. Well within the allowed specs according to the manual and the compensator seems to be good. Nothing loose, no metal shavings on the plug, no scoring from chain slap, etc. It doesnt affect bike performance at all, she has no issues getting going. From what i can tell it only does it while im riding two-up so at this point im just looking for anything else i should check or just an explanation of what could be happening. Thanks all!
Cbordies is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-10-2018, 07:19 PM
Newbie
 
Join Date: Aug 2018
Posts: 1
I also have the same issue with my 17 RGS I also get it when I’m on my own but as you say 2 up seems to instigate the problem more. Really seems like the compensating sprocket to me. Did you find a remedy to your issue?
Richie H-DC is offline  
post #3 of 3 (permalink) Old 08-10-2018, 11:31 PM
Grey beard
 
Little Wing's Avatar
 
Join Date: Nov 2017
Location: oHio!
Posts: 1,206
Garage
how many miles and what kind of "changes" have you guys made to your rides???

i've noticed pinging with different fuels but shell premium seems to alleviate any pinging.
notice it started recently on bp but goes away rather quickly. maybe ecm is catching up with exhaust opening up. dunno.

4800 miles and stock (for now)

__________________________________________________ __________________________________

'18 FLTRX '04 BAR HOPPER '94 FLSTC THE BEST BIKE ...is the one you're on!!!
Little Wing is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Another Primary Noise Thread Pork Chop Troubleshooting for Road Glides 6 04-19-2015 05:34 PM
noise in primary???? craig demel Troubleshooting for Road Glides 4 07-07-2013 11:30 PM
Noise in the primary RoadGlide0611 Engine Related 9 05-25-2013 08:35 PM
Loud noise Primary Beachjeep Troubleshooting for Road Glides 12 11-20-2012 04:06 AM
Front end noise worries... Ranger75 Troubleshooting for Road Glides 23 04-25-2012 11:16 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome