2018 handling issue help needed - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 8Likes
  • 1 Post By Swomack
  • 1 Post By jcarruth
  • 2 Post By Thermodyne
  • 3 Post By porschemann
  • 1 Post By Bruce00
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 07-30-2018, 07:05 AM Thread Starter
Newbie
 
Join Date: Nov 2013
Posts: 3
2018 handling issue help needed

2018 all stock original with 7K on it. Riding home yesterday and all of a sudden it "feels" like a rear flat. Pull over and check tires, nope, all good. Baby it home and check tire pressure once it cools. 36 front and 40 rear. All spec pressures. No fluids leaking, everything tight.
Ride it in to work today. It feels ok for 2 miles, then starts to feel very "greasy". No confidence in bike even at highway posted speeds.

Anyone have any similar situation with SAME bike? It's not tires, pressure, or leaking fluids. It's not the road or anything on it. Open to constructive suggestions... And tonight it goes to the dealer. This bike has full warranty coverage.
porschemann is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 07-30-2018, 07:12 AM
Life Member
 
Swomack's Avatar
 
Join Date: Oct 2014
Location: Prosper, Texas
Posts: 6,281
Garage
Try 41 up front and 39 in the rear.

It won't feel so sloppy riding during the hot summer months.

Your feeling it more up front from being only at 36 psi.

Well it works for me anyways.

Swomack
BigDon likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

My Gallery / Click Below Link

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Swomack is offline  
post #3 of 8 (permalink) Old 07-30-2018, 08:41 AM
Member
 
jcarruth's Avatar
 
Join Date: Apr 2015
Location: Medina, TN
Posts: 501
Garage
Quote:
Originally Posted by porschemann View Post
2018 all stock original with 7K on it. Riding home yesterday and all of a sudden it "feels" like a rear flat. Pull over and check tires, nope, all good. Baby it home and check tire pressure once it cools. 36 front and 40 rear. All spec pressures. No fluids leaking, everything tight.
Ride it in to work today. It feels ok for 2 miles, then starts to feel very "greasy". No confidence in bike even at highway posted speeds.

Anyone have any similar situation with SAME bike? It's not tires, pressure, or leaking fluids. It's not the road or anything on it. Open to constructive suggestions... And tonight it goes to the dealer. This bike has full warranty coverage.
My money is on a faulty tire. Check these things. 1. Jack the bike up and spin both wheels. Look for an out of round tire. If so, take it in and submit a warranty claim. This has happened to me more than once.
2. With the bike jacked up, check the steering head bearings for any side to side or fore and aft play at all by grabbing the lower forks and applying pressure. If any movement at all, take it in and get adjusted.
3. Not likely, check the swingarm for play.
4. Check all wheel bearings.
madmat likes this.

John, Medina, TN - 2003 Honda ST1300 ABS, 2011 Kawasaki KLR 650, 2012 Ducati Monster 1100 EVO
2017 HD Road Glide Special
jcarruth is offline  
 
post #4 of 8 (permalink) Old 07-30-2018, 09:01 AM
Life Member
 
Thermodyne's Avatar
 
Join Date: Jan 2014
Location: South Central PA
Posts: 1,765
Garage
Could also be a bad shock. If one shock fails, it makes the rear end get happy and loose.
madmat and RFG7680 like this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Thermodyne is offline  
post #5 of 8 (permalink) Old 07-30-2018, 04:06 PM Thread Starter
Newbie
 
Join Date: Nov 2013
Posts: 3
Well thanks for all the suggestions. No it's not tires, or pressures, or bearings. None of that gives you the feeling of a flat REAR tire. If you have ever had one, you know what I mean!
What it wound up being is the rear axle moving under torque and braking! Axle is still torqued to 100 ft/lbs. However my witness marks I put on the cams have moved, and the tensioning cam on the RH side has moved 1/16" away from the block on the swing arm.
Remove excess never-sieze from area, retorque and all is good.
Wood, madmat and BigDon like this.
porschemann is offline  
post #6 of 8 (permalink) Old 07-30-2018, 08:54 PM
Prospect
 
Join Date: Jul 2015
Location: Siler City, NC
Posts: 286
Garage
Glad you found the problem! If you were in NC sounds like riding on those [email protected] tar snakes in the summer!

2016 Road Glide Ultra
dreeves is offline  
post #7 of 8 (permalink) Old 07-30-2018, 09:12 PM Thread Starter
Newbie
 
Join Date: Nov 2013
Posts: 3
Quote:
Originally Posted by dreeves View Post
Glad you found the problem! If you were in NC sounds like riding on those [email protected] tar snakes in the summer!
Yup, exactly! Feels like going from tar snakes to a wet soggy lawn and back again. Seems excess anti-sieze on the back side of the adjustment cams may have been a contribuing factor. No idea, never seen one move before...
porschemann is offline  
post #8 of 8 (permalink) Old 07-30-2018, 10:19 PM
Grey beard
 
Bruce00's Avatar
 
Join Date: Jan 2012
Location: Dirty Jersey
Posts: 1,129
Garage
Quote:
Originally Posted by porschemann View Post
Yup, exactly! Feels like going from tar snakes to a wet soggy lawn and back again. Seems excess anti-sieze on the back side of the adjustment cams may have been a contribuing factor. No idea, never seen one move before...

Glad you got it squared away...….those damn tar snakes pucker my ass even when I see them before hitting them
RFG7680 likes this.

2015 RoadGlide Special
Tuned by Jamie @ Fuel Moto w/Rinehart 2>1
Bruce00 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
High speed handling issue eddienelson Troubleshooting for Road Glides 31 06-04-2018 01:24 PM
Boom Bluetooth issue. Help needed [email protected] Audio 0 04-26-2016 03:59 AM
Newer frame - better handling Whats the real difference? Sincecrazy *General Road Glide Discussions/Pictures 29 08-07-2011 03:13 PM
Bike handling with a tour pak jcanrun *General Road Glide Discussions/Pictures 18 05-22-2011 04:54 AM
FLTRU Handling Vs FLHTC Timinfla2 *General Road Glide Discussions/Pictures 9 05-03-2011 08:40 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome