instrument cluster - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 08-20-2018, 12:26 PM Thread Starter
Newbie
 
Join Date: Aug 2018
Posts: 1
Garage
instrument cluster

On my 2016 RGS the tachometer side of the cluster has no lights. the bright light indicator or any light lights up. I had a rear flat and shook the bike really bad and now the only thing on that side working is the tachometer only. Any ideas about what's wrong
dw.usa is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 08-21-2018, 01:39 PM
Administrator
 
MCAdmin's Avatar
 
Join Date: Jan 2012
Posts: 576
Garage
FYI - moving your thread from the Forum Help Desk to Troubleshooting for Road Glides.

Cheers,
Erik
MCAdmin is offline  
post #3 of 4 (permalink) Old 08-21-2018, 02:10 PM
Life Member
 
Swomack's Avatar
 
Join Date: Oct 2014
Location: Prosper, Texas
Posts: 6,283
Garage
Quote:
Originally Posted by MCAdmin View Post
FYI - moving your thread from the Forum Help Desk to Troubleshooting for Road Glides.

Cheers,
Erik
Rookies Right

LOL

Swomack


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

My Gallery / Click Below Link

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Swomack is offline  
 
post #4 of 4 (permalink) Old 08-22-2018, 11:32 AM
Life Member
 
Ohiobellboy's Avatar
 
Join Date: Nov 2012
Location: Canton, oHIo
Posts: 4,722
Pull the speedo and tach off the cluster housing and check all the plugs inside the cluster. Takes 10 minutes.

Sent from my XT1710-02 using Tapatalk

A.K.A OBB
Check out the Ohio Glide Riders community page:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Ohiobellboy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Complete Instrument cluster failure scopet563 Tech Area 6 09-07-2016 05:14 PM
Modding the Instrument Cluster toallow for Risers jm7480 Controls & Handlebars 5 09-18-2015 09:16 AM
Gauge cluster nacelle removal question? tcon287 Tech Area 10 04-07-2015 12:31 PM
Looking for RED instrument cluster lights SIG556 Lighting 17 10-22-2013 09:17 PM
guage cluster / fairing izzi 75093 *General Road Glide Discussions/Pictures 6 10-18-2011 12:08 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome