Check engine light after new bars - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 8Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 01-13-2019, 11:55 AM Thread Starter
Newbie
 
Turbo18's Avatar
 
Join Date: Mar 2018
Location: Pueblo Co
Posts: 12
Garage
Check engine light after new bars

I installed new bars and heated grips and now the engine light is on. I have an 18 RGS. Does anyone know off hand what it might be or how to fix it? Thanks.

Last edited by Turbo18; 01-13-2019 at 12:37 PM.
Turbo18 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 01-13-2019, 12:19 PM
Member
 
BigBlockBobby's Avatar
 
Join Date: Apr 2018
Posts: 467
Normal if you didn't disconnect the battery first. Try disconnecting the battery for a min. If it comes back you may have a bad connection, cut wire, forgot to plug something in, or a chaffed wire.
Turbo18 likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Good decisions come from experience, and experience comes from bad decisions.
BigBlockBobby is offline  
post #3 of 13 (permalink) Old 01-13-2019, 12:27 PM
Newbie
 
JSDonaRGU's Avatar
 
Join Date: Jul 2017
Location: Utah
Posts: 39
Garage
First reinstall the original bars, if the light goes out you know that the problem is.

Actually I remember this article FuelMoto to reset codes. If you did not disconnect the battery you might of tripped a code on accident. I would start with a resetting the codes.

Hope it helps.
Turbo18 likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

My Mods: Vance and Hines FP3, Arlen Ness Big Sucker Stage 1, Legend Suspension Revo-A
JSDonaRGU is offline  
 
post #4 of 13 (permalink) Old 01-13-2019, 12:35 PM Thread Starter
Newbie
 
Turbo18's Avatar
 
Join Date: Mar 2018
Location: Pueblo Co
Posts: 12
Garage
Ill try disconnecting the battery and hope that solves it! Thanks guys.
Turbo18 is offline  
post #5 of 13 (permalink) Old 01-13-2019, 12:45 PM
Life Member
 
RGKen's Avatar
 
Join Date: May 2012
Location: Jax, FL
Posts: 3,932
Garage
Quote:
Originally Posted by Turbo18 View Post
Ill try disconnecting the battery and hope that solves it! Thanks guys.

You don't need to disconnect the battery. Just clear the codes. You should have pulled the main fuse before you disconnected the speedo and tach. That is the reason the check engine light is on because it threw some codes for that. Once you clear them the check engine light should stay off unless you have something wrong.
crazy4ink and craigffb like this.

2018 FLTRXS
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
RGKen is offline  
post #6 of 13 (permalink) Old 01-13-2019, 12:48 PM Thread Starter
Newbie
 
Turbo18's Avatar
 
Join Date: Mar 2018
Location: Pueblo Co
Posts: 12
Garage
Awesome! thank you very much. I'll give that a shot tonight. Really appreciate the info.
RGKen likes this.
Turbo18 is offline  
post #7 of 13 (permalink) Old 01-13-2019, 02:12 PM
Grey beard
 
craigffb's Avatar
 
Join Date: Sep 2018
Location: Clarksville, TN
Posts: 865
Garage
Quote:
Originally Posted by RGKen View Post
You don't need to disconnect the battery. Just clear the codes. You should have pulled the main fuse before you disconnected the speedo and tach. That is the reason the check engine light is on because it threw some codes for that. Once you clear them the check engine light should stay off unless you have something wrong.






Sent from my iPhone using Tapatalk
Turbo18 likes this.

2019 Road Glide Special/2010 Street Bob
craigffb is online now  
post #8 of 13 (permalink) Old 01-18-2019, 02:57 PM
Grey beard
 
Taz_FL's Avatar
 
Join Date: Feb 2015
Location: Jacksonville, Florida
Posts: 1,132
Garage
Quote:
Originally Posted by RGKen View Post
You don't need to disconnect the battery. Just clear the codes. You should have pulled the main fuse before you disconnected the speedo and tach. That is the reason the check engine light is on because it threw some codes for that. Once you clear them the check engine light should stay off unless you have something wrong.
This is correct, I ran into the exact same thing after installing new bars after christmas. All you have to do is clear the codes and your issue is solved.
SharknoseScott and jimAZ like this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Taz_FL is online now  
post #9 of 13 (permalink) Old 01-18-2019, 03:01 PM
Newbie
 
jimAZ's Avatar
 
Join Date: Aug 2018
Location: Scottsdale AZ
Posts: 48
Garage
The fuelmoto page above tells you exactly what to do No big deal.

Hello from Arizona
2018 RGU - First Harley, Long time Rider

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jimAZ is offline  
post #10 of 13 (permalink) Old 06-21-2019, 08:31 AM
Newbie
 
Join Date: Jun 2019
Posts: 3
How do you clear the codes?
BlackknightRGS is offline  
Reply

Tags
bars , engine light

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Buky Bars - Product Review redbeard719 Controls & Handlebars 20 10-29-2013 06:50 PM
check engine light mdjr47 ECM/Fuel Management systems 7 07-06-2013 08:48 AM
Check engine light bigtommy55 Controls & Handlebars 1 06-28-2013 10:25 AM
FuelPak Check Engine Light Question Pablo22 ECM/Fuel Management systems 12 05-24-2012 12:44 PM
Oil Overfill and Check Engine light Biker Tom Troubleshooting for Road Glides 5 09-15-2010 07:01 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome