Voltage Issue - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 4Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 21 (permalink) Old 01-29-2019, 08:08 AM Thread Starter
Newbie
 
Mulchman's Avatar
 
Join Date: Apr 2018
Location: Tampa, Florida
Posts: 20
Garage
Voltage Issue

So the last two times I have been riding the 2012 Road Glide Ultra I have notice the voltage
intermittently fluctuating. First time it dropped to 11.4, and then after 15min it spiked up to 14.7.
It stayed that way the rest of the way home. Second ride (most recent) it dropped to 12.1 and stayed there for a good 6min of highway driving before it rose up to 14.2. I checked to battery and performed
the stator test. Both seem in order, so I am suspecting it is the Voltage Regulator. I read up on some forum posts here and it seems others with the 12's have also had the same issue. RMStator has a
(upgraded) voltage regulator for $129. Has anyone had any experience with RMStator. Not real crazy
about spending the money on an issue that is intermittent, but I dont want to buy a $40 Ebay regulator
that is probably from China.
Mulchman is offline  
Sponsored Links
Advertisement
 
post #2 of 21 (permalink) Old 01-29-2019, 08:21 AM
Grey beard
 
hd4cruzin's Avatar
 
Join Date: Oct 2011
Location: Santa Clarita, CA
Posts: 1,317
Sure sounds like the voltage regulator. I have a 2012 as well they had a recall on them when they first came out and mine was replaced. Then 5 years later while traveling across country ran into the same issue you are having. Pulled into a dealer and had it replaced.

Sorry canít help on the make of regulator you are looking for but you should replace soon before you get caught on the side of the road.

Good luck

2012 FLTRX BBP
Drago Diablo 2.5 107" 580 cam, Drago 2 pipe and TTS, 14.5" Madstad, Vindikta 12" Maruaders, Corbin Solo
6.5" H.A.T. speakers and Arc 125.2 amp
hd4cruzin is offline  
post #3 of 21 (permalink) Old 01-29-2019, 08:37 AM
Life Member
 
JayKS's Avatar
 
Join Date: Sep 2011
Location: Wichita, KS
Posts: 2,469
I've not heard of RMStator, but personally when I have to replace a stator or regulator, I go with Cycle Electric. Very solid stuff.

According to CE's website, CE-608 would be the one for your bike: http://www.cycleelectricinc.com

It's available on Amazon, just search for CE-608.

You can find it other places as well. PhatPerformance, Direct Cycle Parts, etc.

Good luck with getting it resolved. Cheers. -Jay
Mike U and duglauraflht like this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
JayKS is offline  
 
post #4 of 21 (permalink) Old 01-29-2019, 12:42 PM
Life Member
 
Mike U's Avatar
 
Join Date: Aug 2012
Location: New York
Posts: 6,147
Quote:
Originally Posted by JayKS View Post
I've not heard of RMStator, but personally when I have to replace a stator or regulator, I go with Cycle Electric. Very solid stuff.



According to CE's website, CE-608 would be the one for your bike: http://www.cycleelectricinc.com



It's available on Amazon, just search for CE-608.



You can find it other places as well. PhatPerformance, Direct Cycle Parts, etc.



Good luck with getting it resolved. Cheers. -Jay


Iíll second what Jay said!
I have a 2012 Custom and replaced the stock VR with a Cycle Electric one about 2 years ago just for preventive measures. I have since purchased a Cycle Electric Stator that I will be putting in come Spring, just because.
Mike U.


Sent from my iPhone using Tapatalk

USMC 1975-1977
Semper Fi!
Nothing else matters!
Mike U is online now  
post #5 of 21 (permalink) Old 01-29-2019, 02:41 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,067
Garage
Quote:
Originally Posted by hd4cruzin View Post
Sure sounds like the voltage regulator. I have a 2012 as well they had a recall on them when they first came out and mine was replaced. Then 5 years later while traveling across country ran into the same issue you are having. Pulled into a dealer and had it replaced.

Sorry canít help on the make of regulator you are looking for but you should replace soon before you get caught on the side of the road.

Good luck
Bad VR can take out a good battery also.
Mike U and Trendkill like this.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
post #6 of 21 (permalink) Old 01-29-2019, 04:31 PM
Prospect
 
kiwidave's Avatar
 
Join Date: Sep 2013
Location: Melbourne, Australia
Posts: 263
Since the alternator system came in for Big Twins at the start of the 1970s, regulators have been the WEAKEST point on our bikes.

Cycle Electric makes a top-quality product.

Cheaper ones can be bad out of the box, yes, even brand new.

I have to smile at folks who observe that that they have had 2 go down in 5 years. That's actually really good.

Here's a tip: since adding an EXTRA earth wire from regulator mount bolt to nearby ground i.e. forward control / footpeg / floorboard mount bolt, I have not had a regulator fail on either of my Shovelheads in the last 7-8 yrs. Before then, it was almost an annual event.

Gary is right ^^^^^ trickle-recharge and then check your battery, as the failed regulator may have caused permament damage.
kiwidave is online now  
post #7 of 21 (permalink) Old 01-29-2019, 06:16 PM
Hangaround
 
Join Date: Mar 2012
Location: ct
Posts: 147
My 2 cents with a 12 ultra. Voltage did the same for me for some 3 weekends. Fourth weekend while on a 2 day trip, voltage dropped below 10. Stopped for coffee and bike never started. A AAA tow job to nearest Harley dealer, turned out to be the battery. Twenty-five minutes later I was back on the road.

2012 Road Glide Ultra
antant is offline  
post #8 of 21 (permalink) Old 01-29-2019, 06:46 PM
Life Member
 
Road dawg's Avatar
 
Join Date: Oct 2011
Location: Long Island, New York
Posts: 2,191
New to this information, is it the 2012s that had issues only? I have a 2011 FLTRX with 36k and the original voltage regulator and I have two long trips planned this summer you guys got me thinking? I know some of the issues were from the heat of the oil cooler, but my 96 inch does not have one, wonder if this is a factor as well.

When all else fails, hell there is always beer!

Last edited by Road dawg; 01-29-2019 at 06:53 PM.
Road dawg is online now  
post #9 of 21 (permalink) Old 01-29-2019, 06:54 PM
Life Member
 
Road dawg's Avatar
 
Join Date: Oct 2011
Location: Long Island, New York
Posts: 2,191
Quote:
Originally Posted by Mike U View Post
I’ll second what Jay said!
I have a 2012 Custom and replaced the stock VR with a Cycle Electric one about 2 years ago just for preventive measures. I have since purchased a Cycle Electric Stator that I will be putting in come Spring, just because.
Mike U.


Sent from my iPhone using Tapatalk
How many miles did you have on your scoot when you replaced it?

When all else fails, hell there is always beer!

Last edited by Road dawg; 02-03-2019 at 04:02 PM.
Road dawg is online now  
post #10 of 21 (permalink) Old 01-29-2019, 07:03 PM
Life Member
 
Mike U's Avatar
 
Join Date: Aug 2012
Location: New York
Posts: 6,147
Quote:
Originally Posted by Road dawg View Post
How many miles sis you have on your scoot when you replaced it?


RD I think it was in the neighborhood of 15,000 miles. I have over 30,000 on her now.
Mike U.


Sent from my iPhone using Tapatalk

USMC 1975-1977
Semper Fi!
Nothing else matters!
Mike U is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Varying voltage Joesquid Troubleshooting for Road Glides 29 09-11-2017 01:16 PM
BDL enclosed primary installation issue hawk06Glide Engine Related 7 04-10-2017 12:13 PM
Volume Fluctuates sdjiggs Audio 12 09-18-2015 02:20 PM
Voltage problems.... kouack Troubleshooting for Road Glides 17 09-03-2015 07:04 AM
Charging Issues - Voltage Reg AGAIN?! TracknTail Troubleshooting for Road Glides 3 10-07-2013 11:04 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome