Blinking ABS LIGHT after VIED install - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 2Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 03-04-2019, 03:17 PM Thread Starter
Hangaround
 
Join Date: Jul 2014
Location: Comfort Tx
Posts: 55
Blinking ABS LIGHT after VIED install

I installed VIEDs on the O2 sensors which involved adding a ground wire to the negative battery terminal and adding a ground on the brace between the front frame down tubes. Now my ABS light is blinking. I'm an old Shovelhead , EVO, Carburetor guy so I have a lot to learn about Fuel injection, ABS, Sensors etc. Any thoughts or advise appreciated. Thank you

BE Careful when all of a sudden - nothing happens!!
fitscott is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 03-04-2019, 03:57 PM
Grey beard
 
craigffb's Avatar
 
Join Date: Sep 2018
Location: Clarksville, TN
Posts: 897
Garage
Is this while riding it or while it's sitting?

2019 Road Glide Special/2010 Street Bob
craigffb is offline  
post #3 of 12 (permalink) Old 03-04-2019, 04:18 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,064
Garage
What was the ground on the frame tube for? My FL - vied-10 only grounded to the battery.
What year bike ?

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
 
post #4 of 12 (permalink) Old 03-05-2019, 06:35 AM Thread Starter
Hangaround
 
Join Date: Jul 2014
Location: Comfort Tx
Posts: 55
I may have asked the question too soon - I haven't been able to ride it yet so maybe there is no problem - the Vieds I have plug into the oxygen sensors then back to the wire harness - they both have a ground wire and the instructions say 2009 and newer need to be grounded - thank you for your replies - It's 22 here today so I won't be riding it for a while

BE Careful when all of a sudden - nothing happens!!
fitscott is offline  
post #5 of 12 (permalink) Old 03-05-2019, 06:47 AM
Member
 
Stoic Joker's Avatar
 
Join Date: Feb 2016
Posts: 660
On my 10, when you first start the bike the ABS light always flashes (slowly) until you start moving.

Scarlet Red 2010 Road Glide Custom named Trixie - She's a flashy little minx..
Basic black 1981 Tour Glide Classic named Alice - She's a sleeper project.
Stoic Joker is offline  
post #6 of 12 (permalink) Old 03-06-2019, 05:42 AM Thread Starter
Hangaround
 
Join Date: Jul 2014
Location: Comfort Tx
Posts: 55
I'll take it for a ride and post the results . I need to get an owners manual for it - It's a 2009 RG CVO. Thank you for the help!

BE Careful when all of a sudden - nothing happens!!
fitscott is offline  
post #7 of 12 (permalink) Old 03-06-2019, 09:25 AM
Life Member
 
skratch's Avatar
 
Join Date: Mar 2010
Location: louisiana
Posts: 3,894
Quote:
Originally Posted by Stoic Joker View Post
On my 10, when you first start the bike the ABS light always flashes (slowly) until you start moving.
yeah, any hd with abs is that way.

I understand the concept of reality, but find it too confining for a way of life.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
skratch is offline  
post #8 of 12 (permalink) Old 03-07-2019, 06:44 AM Thread Starter
Hangaround
 
Join Date: Jul 2014
Location: Comfort Tx
Posts: 55
well you guys were right - the only thing wrong with my bike is the nut that holds the handlebars - I've only had the bike a couple weeks so I have a lot to learn. I appreciate your kind responses very much.

BE Careful when all of a sudden - nothing happens!!
fitscott is offline  
post #9 of 12 (permalink) Old 03-07-2019, 07:03 AM
Member
 
Stoic Joker's Avatar
 
Join Date: Feb 2016
Posts: 660
Quote:
Originally Posted by fitscott View Post
well you guys were right - the only thing wrong with my bike is the nut that holds the handlebars - I've only had the bike a couple weeks so I have a lot to learn. I appreciate your kind responses very much.

Been there, done that ... I went from an 87 FLHTP that I'd had for 20 years to a 10 TC that I couldn't lower the idle on (WTF?!?). The first time the 10 decided to glitch on me...I bought an 81 Shovelhead FLTC, that I knew I could depend on..
fitscott likes this.

Scarlet Red 2010 Road Glide Custom named Trixie - She's a flashy little minx..
Basic black 1981 Tour Glide Classic named Alice - She's a sleeper project.
Stoic Joker is offline  
post #10 of 12 (permalink) Old 03-07-2019, 07:11 AM
Newbie
 
Mulchman's Avatar
 
Join Date: Apr 2018
Location: Tampa, Florida
Posts: 20
Garage
Quote:
Originally Posted by fitscott View Post
well you guys were right - the only thing wrong with my bike is the nut that holds the handlebars - I've only had the bike a couple weeks so I have a lot to learn. I appreciate your kind responses very much.
Don't feel bad, that had me too first time I sat on my ABS Glide...
Mulchman is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Street Glide/TRX rear light bar on Ultra SurlyBoy Lighting 9 02-26-2017 03:03 PM
Turn signals and brake light LED install billd76 Lighting 3 09-21-2015 03:49 PM
2013 RG Oil Bud INstall tips Big_Mo *General Road Glide Discussions/Pictures 14 08-24-2014 04:39 PM
Oil Bud Oil Cooler install 2013 RG ultra Big_Mo Aftermarket Accessories 0 08-09-2014 09:32 AM
UPDATE my 5x7 Hogtunes speaker and amp install SKULLZ Aftermarket Accessories 8 04-06-2010 09:45 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome