WTH?? Throttle, Check Engine IDK?? - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 04-22-2011, 04:11 PM Thread Starter
Hangaround
 
Join Date: Mar 2011
Location: Baton Rouge, LA
Posts: 179
WTH?? Throttle, Check Engine IDK??

Ok I have a 2011 RGC with around 900mi. I bought it new from a dealer and haven't done anything other than fuel it, keep it clean, and routine checks (oil, tires etc.). Some times when I start the bike doing the "Harley sequence", in neutral the bike will rev really high without even touching the throttle or handlebars for that matter. Then the check engine light will come on and stay on. Afterward the check engine light will remain on for each restart regardless if it revs on it's own or not. After the bike sits for a while say a few hours it may not do it on the next restart. It will also do this uncontrolled revving sometimes when I pull into a parking spot and prepare to shut down. The bike runs fine otherwise. Any ideas what's causing this? I've tried searching but I don't even know what to call this problem.
taker96 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 04-22-2011, 04:51 PM
Member
 
DemonCity's Avatar
 
Join Date: Jul 2010
Location: Fresno
Posts: 539
Sounds like a program problem. Takenit in & they'll hook it up & do a diagnostic.

1%DFFD1%
DemonCity is offline  
post #3 of 8 (permalink) Old 04-22-2011, 06:19 PM
Hangaround
 
Join Date: May 2010
Location: manalapan NEW JERSEY
Posts: 62
i think you should let the bike idle before shutting down ,may b thats it
The Shark Rider is offline  
 
post #4 of 8 (permalink) Old 04-23-2011, 12:36 PM
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,528
Check for DTC codes. If the bike show any codes clear them. The Throttle By Wire bike will have a memory @ the ECM in other words if the bike is shut off while at a higher RPM the ECM will memorize the engine speed and set the idle speed at the memorize RPM. It is best to shut the bike down with your right hand using the main ignition switch. To correct the high idle problem make sure the run/stop switch located on the handlebars is in the run position then take the main ignition and turn it on until the check engine light turns off repeat this on/off procedure 5 times making sure the check engine light turns off each time, this should reset the idle speed to factory settings.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
post #5 of 8 (permalink) Old 04-23-2011, 01:58 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,128
Garage
Dealer/Warranty . The memory should not rev it high enough to throw a code.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
post #6 of 8 (permalink) Old 04-23-2011, 02:11 PM
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,528
Yes the bike is under warranty use it if you need to. The check engine light will stay on when there is a code stored in the memory. Clear the code, the check engine light will go off, if the light come on again then there is a problem with the bike so take it to the dealer. The code that is showing may not have anything to do with the idle problem. Try cycling the main ignition switch 5 times making sure the check engine light turn off on each cycle. Doing the ignition cycle WILL reset the idle back to factory settings.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
post #7 of 8 (permalink) Old 05-05-2011, 08:21 AM Thread Starter
Hangaround
 
Join Date: Mar 2011
Location: Baton Rouge, LA
Posts: 179
The saga continues...

Well the bike started running worse. It was sputtering through acceleration and dying at idle so I took it to the dealer. They looked at it and found a loose connection at the throttle actuator or something. While on my way to pick it up it they called me back to tell me it was throwing codes again that they couldn't clear because it's telling them to replace the ECM. So now I have to wait until Tuesday for that to come it and get my bike back.

This is my first motorcycle and so far I'm not impressed with the experience. It's one month old and it's already crapping out on me. Sure I get that this kind of thing happens, but I'm not crazy about how the dealer seems so nonchalant about making it right. I'm starting to regret this purchase . Hopefully this is just an anomaly and everything will be ok moving forward.
Thanks to you guys' directions I did pull the codes before taking it in. Here they are in case anyone else has a similar problem.

ECM Codes: 5/2/2011
Cleared P0107 – MAP sensor low/open
Cleared P0651 – 5v ref 2 out of range
Won’t Clear P1510 – Throttle actuator control limited performance PN32933-11
Won’t Clear P2127 – Twist grip position sensor 2 low/open
Cleared P2138 – Twist grip position sensor correlation error
taker96 is offline  
post #8 of 8 (permalink) Old 05-05-2011, 09:44 PM
Member
 
DemonCity's Avatar
 
Join Date: Jul 2010
Location: Fresno
Posts: 539
Quote:
Originally Posted by taker96 View Post
Well the bike started running worse. It was sputtering through acceleration and dying at idle so I took it to the dealer. They looked at it and found a loose connection at the throttle actuator or something. While on my way to pick it up it they called me back to tell me it was throwing codes again that they couldn't clear because it's telling them to replace the ECM. So now I have to wait until Tuesday for that to come it and get my bike back.

This is my first motorcycle and so far I'm not impressed with the experience. It's one month old and it's already crapping out on me. Sure I get that this kind of thing happens, but I'm not crazy about how the dealer seems so nonchalant about making it right. I'm starting to regret this purchase . Hopefully this is just an anomaly and everything will be ok moving forward.
Thanks to you guys' directions I did pull the codes before taking it in. Here they are in case anyone else has a similar problem.

ECM Codes: 5/2/2011
Cleared P0107 – MAP sensor low/open
Cleared P0651 – 5v ref 2 out of range
Won’t Clear P1510 – Throttle actuator control limited performance PN32933-11
Won’t Clear P2127 – Twist grip position sensor 2 low/open
Cleared P2138 – Twist grip position sensor correlation error
Sorry to hear that. U should be fine with new ECM

1%DFFD1%
DemonCity is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
WTH is up with these lights 93-331-29psi *General Road Glide Discussions/Pictures 13 08-27-2014 08:50 PM
tuner no tuner WTH????? motosig102 Intake and Exhaust 19 06-16-2013 03:36 PM
Windshield grommetts, WTH! ChromeYellow67 Windshields 22 12-14-2011 02:09 PM
Wth? jonesbrass *General Road Glide Discussions/Pictures 14 05-18-2011 03:58 PM
Illumabezel WTH!! dgass38 Lighting 9 04-25-2011 12:34 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome