Screwed up - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-29-2011, 12:01 PM Thread Starter
Newbie
 
Join Date: Jun 2011
Location: Minneapolis, mn
Posts: 2
Screwed up

I just purchased my 2nd RG and it had a factory installed amp under the "pizza box" storage area and a third brake light on the storage area. Well I removed the "pizza box" (don't need it riding in the city) and disconnected the amp wiring harness and light plug. Immediately my radio quit working, so I removed the amp from the pizza box and plugged it back in. Still not working. Now my battery is dead. Any suggestions I need help!
plantman66 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-29-2011, 03:31 PM
Life Member
 
DED HD's Avatar
 
Join Date: Jun 2010
Location: Iowa City
Posts: 4,022
This topic has been presented in a couple of forums. Might have to do some investigaing. Some will tell you it simply cannot be done on the 2011s.
IN 2011, I think the harness changed. You will have to have the amp hooked up, or move the amp to your saddlebag. Or have some kind of switch or something. Its been done, but it isnt as simple as it once was.
or you will have to rewire your speakers and not have an amp anymore, unless you buy an aftermarket amp and put it in the fairing.

'10 Red Custom:
check out my build thread for pix and mods
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
DED HD is offline  
post #3 of 3 (permalink) Old 06-29-2011, 08:18 PM Thread Starter
Newbie
 
Join Date: Jun 2011
Location: Minneapolis, mn
Posts: 2
Screwed up

I reattached the amp and put it in the saddle bag. Still no go. Is there a reset or soemthing.
plantman66 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
HD stage 4 installed and the dyno man screwed up ironmark Engine Related 16 01-29-2013 11:41 PM
Think I just screwed up my weekend dirt.bagger.11 Intake and Exhaust 6 06-17-2012 11:26 AM
Screwed this one up... SGT_Rob *General Road Glide Discussions/Pictures 15 02-10-2012 02:16 PM
Screwed up Tank Badge Maxcustody Road Glide Specific Discussions 18 02-06-2012 12:20 AM
I screwed Up Royally Today! spraypilot *General Road Glide Discussions/Pictures 18 02-19-2011 06:25 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome