04 starting problem - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 07-05-2011, 02:09 AM Thread Starter
Hangaround
 
WildBill's Avatar
 
Join Date: Apr 2011
Location: Northwood Ohio
Posts: 67
04 starting problem

When attempting to start my bike it sometimes stumbles like it deosn't have enough power to crank over, then everything blacks out no power to the lights or anything at all.
Has anyone ever had this problem? Has me very concerned because I ride alot of miles and do not want to be left stranded.
Thanks
WildBill
WildBill is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 07-05-2011, 06:39 AM
Grey beard
 
thedude's Avatar
 
Join Date: Oct 2009
Location: Neponset IL
Posts: 912
How about a new battery.
thedude is offline  
post #3 of 5 (permalink) Old 07-05-2011, 07:30 AM
Grey beard
 
Redfish-Joe's Avatar
 
Join Date: Sep 2010
Location: Mississippi Gulf Coast
Posts: 1,361
Older models have a circuit breaker that will get weak over time. Newer models have a master fuse.

2011 FLTRX,Fat Shots Pipes,Wind Vest Windshield,Dobeck EJK, Chrome forks, 2+2 bars, SE Ventalator breather, Andrews 48 H Cams, Rivera Taper Lite Pushrods
Redfish-Joe is offline  
 
post #4 of 5 (permalink) Old 07-05-2011, 09:07 AM
Hangaround
 
Vettster's Avatar
 
Join Date: Apr 2010
Location: Veracruz, Ver. Mexico
Posts: 142
Check the ground lug underneath the front of the seat. Make sure everything is tight.
(Don't ask me how I know this.)

Ride Safe,
Vettster
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Vettster is offline  
post #5 of 5 (permalink) Old 07-05-2011, 02:05 PM Thread Starter
Hangaround
 
WildBill's Avatar
 
Join Date: Apr 2011
Location: Northwood Ohio
Posts: 67
Vett the connection was tight but after shaking it bike powered back up. Took the nut off and checked the and noted some slight corrosion so cleaned it up and reconnected it. Now the Darkside has power again. Took that stupid little strap that goes over the seat off so if I have the problem on the road just unscrew the seat check it and hopefully be ready to roll again. One of the reasons this bike had not been ridden in 2 year prior to buying it so I may be finding little things for a while.
Thanks to everyone for the replies and the ideas.
WildBill
WildBill is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem starting at times Headbanger Troubleshooting for Road Glides 19 02-08-2015 04:05 PM
Initial starting problem spider445 Troubleshooting for Road Glides 7 03-15-2013 01:14 PM
Problem starting when hot. hoosierboarder Troubleshooting for Road Glides 2 08-02-2012 06:04 AM
Starting problem Black Sheep Troubleshooting for Road Glides 7 10-23-2011 09:10 PM
04 road glide cruise problem fatboyjdb Troubleshooting for Road Glides 1 06-22-2011 08:42 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome