Stock RGU Air Shocks not holding - Road Glide Forums
Troubleshooting for Road Glides List your Road Glide problems here, and DR. Ruth will answer them.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-27-2011, 01:18 AM Thread Starter
Member
 
b104396's Avatar
 
Join Date: Oct 2010
Location: Spokane Washington
Posts: 363
Stock RGU Air Shocks not holding

Anyone else have problem on their 2011 RGU of shocks not holding pressure? Just finished 2400 mile trip with wife and every morning pressure read zero and would re-inflate to 50 psi. By mid day could tell most of the pressure had been lost. Mentioned to dealer on last service and they said pressure held overnight but bike not ridden or loaded with two up and full bags. Bike is going in next week for 5k service and I want to force issue with dealer to fix or replace.

2011 103" RGU Merlot Sunglo V&H Rounds, SERT, Fullsac X Pipe, SE/AC, SE255 cams,Brightass, IPOD Kit, Zumo 660, Hammock, Heritage Bars, Bag Guards, Tire Presssure Monitoring.
b104396 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-27-2011, 01:33 AM
Member
 
Shark daddy's Avatar
 
Join Date: Jun 2011
Location: Portland, OR
Posts: 715
There is a hose leak or faulty boot in one of the shocks, could even be a slow leak in the valve stem. They should hold air indefinitely with no drop in pressure. Ask the dealer to look harder and take it for a reasonable test ride. Good luck. Shark Daddy from Portland, ORE
Shark daddy is offline  
post #3 of 4 (permalink) Old 07-27-2011, 01:53 AM
Life Member
 
Join Date: Sep 2010
Location: missoula,mt
Posts: 2,016
Mine do not loose any air pressure over time but they still don't feel great. I had progressive 440's on my past bike and am going to go that route or something similar in the future.
jeff is offline  
 
post #4 of 4 (permalink) Old 07-27-2011, 11:04 AM
Life Member
 
DED HD's Avatar
 
Join Date: Jun 2010
Location: Iowa City
Posts: 4,022
Mine were leaking or not holding air at all. The hose was rubbing on a sharp edge of the frame on the left side of the bike where it goes under the seat causing a hole in the hose. Simple fix, by replacing the hose.

'10 Red Custom:
check out my build thread for pix and mods
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
DED HD is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Want your reasons for not running air shocks adown Suspensions 4 06-18-2016 06:09 PM
DC dealer holding a Nation of Islam ride??????? DC-3Mek General Off-Topic Discussions 23 09-04-2015 07:19 AM
So Much for HD holding their value over Metric bikes ironmark *General Road Glide Discussions/Pictures 30 04-04-2014 11:42 AM
Leaking air shocks - New Works Shocks RoadGlide5150 Equipment-RG 0 10-29-2010 04:04 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome